Setting Up My Cloud

I am at my wits’ end trying to set up my storage device.

I have tried following online instructions, which state that a page will appear after step 4; no page appears.

I then tried to set up the device on my router; the protocol asks for a security key number which is not present on my device.

Most importantly, there no guidance on how to transfer files.

The site is not particularly accessible or a friendly environment for someone like me who is used to Plug and Play, along with basic user-friendly language: there appears to be an assumption that everyone is an IT wizard. What kind of company sells items that are not detectable by the most widely used home computer platforms?

I have seriously considered throwing the device out the window - I live on the 18th floor.

@OtisBD Do you know if you have a 1st or 2nd generation My Cloud. Use the following link for more information on both and the User Manuals.

Thanks for the link; it’s no use as it contains hyperlinks that just take you to the new installation process.

I have lost all patience trying to get a solution from WD, as their system does not recognise my product serial number; consequently I cannot get access to online help.

You would think a company selling high ticket products would make it easy for customers to contact it - not WD: they are a shower of cowboys.

@OtisBD Which WD device do you own? What kind of Computer do you own and give information about it such as, operating system, amount of RAM and size of hard Drive.

Have you looked at the bottom of this page and checked to see what is available under, Contact WD?

I believe im posting in correct area. Not to familiar with this stuff. I have a MyCloud. Been using it for years. I have two laptops connected to it. Attempting to get third connected, but am unsuccessful. Two connected are windows 10. The new one is a windows 8.1. I did download the software, and performed a test upload on the machine. I could see that it was there by viewing from the win10 machine. But when i try to open the ‘main storage’ share on the win8 machine, it complains that i dont have access. i did add a third user to the cloud, and granted access. it says that i may not have access to this network resource. Any ideas??


The second paragraph in the warning dialog tells you the problem. Windows generally does not like it when you use a second (additional) login (password)to access the My Cloud. For example, you already have logged into the My Cloud (via Windows File Explorer) using one set of My Cloud login information. Yout hen attempt to use a different set of My Cloud login information to access a different Share on the My Cloud. The error message is the result.

Thee are a re things one can do. First is to access the My Cloud Dashboard and give the existing My Cloud user account one already usedon Windows permissionis to access the the other Share.

Another workaround is to create a new Windows User account. Log into Windows with that new account. Then use the second My Cloud user account to access the Share.

Or one can try removing the My Cloud Credentials from the Windows Credentials Manager, reboot the Windows PC then see if one can access the other Share using the second My Cloud login.

Thank you, thank you, thank you.
I had no idea what windows credentials are.
Never messed with them before.
You opened my eyes.
I went about it a bit different, but got there.
I deleted the MyCloud crediantial and shut down and back up.
Tried logging into MyCloud, still no success.
Renamed PC and uninstalled WD access.
Shut down and back up.
Reinstalled WD access, and VOILA.

Thank you Bennor