Setting up keys for SSH login / running a cronjob [SSH solved, only cronjob left]

First out, yes I know this will void warranty, I dont care :smile:

I am trying to set up SSH with keys for login on My Passport Wireless, but so far I have not been able to get it to work. I get “the server rejected out key”. I set up My Book the same way, and it works fine, and I am more than familiar with setting this up on Linux servers. But for the best of me, I cant get it to work on this Passport Wireless. The permissions on the files and dirs are correct, so is the authorized_keys file and sshd_config file.

The fact that is has two home dirs for root might be a source for trouble, both /root and /home/root/ but I have tried them both.

Has anyone set up a Passport Wireless with keys I would be very grateful for tips :slight_smile:

SOLVED SSH KEYS PROBLEM, as per usual the settings for the entire /home dir was wrong, chmodding it with 0755 solved it, as well as 0700 for .ssh and 0600 for authorized_keys

The other challenge is to get a script running every night at 0100 hours. I have a script, foo.sh, that can be executed manually without any errors, but it will not run (it is not called/started) when I put it in /etc/cron.d/ and with the lack of a crontab I am not sure how to make it work. Any ideas, suggestions would be appreciated.

Have a nice holiday everyone, kind regards Knut

Hi,

Let’s see if any of the users are working on this and can share some information about it.