Setting up a WD TV Play using the composite port?

My TV is too old to support 1080P resolution. So I’m using the composite cable to attach the Play to my TV.

The Play’s blue light comes on but nothing appears on my TV screen when I push the Power button on the remote. I’ve attached the composite cable per the instructions in the User Guide that I downloaded.

How do I get the Play Composite port to work?


Hello, leave the composite cable connected to the tv and the media player, and then reset the WD TV by pressing the reset button, this should get it working using the composite cable.

Thanks for the suggestion. Unfortunately, per someone else’s, I’ve already tried the reset button with negative results.


That’s weird, do you have a TV that is capable of using HDMI? If so, You can try to connect the WD TV to that TV and then manually change the settings just view this page on the manual. If that doesn’t work you might have a bad cable or a bad media player and I would recommend you to contact support.

My HDMI TV only supports interlaced video. I have an old CRT TV that only has composite input.

I tried both. BOTH showed only a black screen although I could hear an audio hum from the CRT TV.

I tried to contact Support but my model and serial number were rejected as invalid. So at this point I plan on returning the Play.