Setting individual file properties - Read/Only setting won't save


#1

Hi,

We have set up our WD Sharespace to be a fileserver. Our workstations have access to it through a network share. Our workstations either have Windows XP, Windows Vista, or Windows 7.  All folder sharing permissions have been set to public access.

We have certain files that should not be modified. As a result, we tried to set them as read-only in the file properties, but the setting will not save. I know you can set up shares as being read/write or read only. But is it possible to have files in a read/write share in the WD Sharespace that can be set to either read-only or read-write in the same share? We didn’t have this problem when we had this on a server running Windows 2003 Server.

We tested if it was OS specific, but the problem existed in all OS. I have to believe there is some setting on the WD Sharespace that will allow me to do thism. I cannot find it in any of the documentation. Any suggestions?


#2

The problem is that the ShareSpace runs Linux and file properties don’t map exactly from Linux to Windows (or vice versa).  Your best option is to remove public access to the given share(s) and grant permissions to the share(s) based on username in the ShareSpace’s web UI.

:smiley:


#3

Thanks for the reply.

Unfortunately, that won’t solve my problem, as the read-only files are used as templates for creating new files. If the file is not read-only, then someone could accidently save over the file. It appears I will stop using this drive as a file server, and move my files back to a real server. I will just use this for file storage. It’s a ashame since there is so much space on it. The web UI for this drive could be vastly improved, with more user-friendly features. Otherwise, it serves it’s purpose as a storage device. Funny that other manufacturers like Buffalo, don’t have this issue. I’m not sure about Seagate.

Thanks again.

Jean


#4

  What you’re looking to have done can be done, yes… I actually do so myself quite a bit, so I know from practical experience that it’s workable…

  The trick is that you need to enable the ssh-login ability of the device, then login via a terminal-emulator program using ssh to the device. This opens up access to a DOS-like command-line-interface - the Linux host operating system actually…

  From there you need to browse over to the particular directory and file you’re interested in and manually change the relevant rights on the target files. If you remove write-access for all the file owners your file becomes 100% read-only via normal access until and uness you change it manually again.

  This requires a little familiarity with command-line interfaces - more particularly Linux and it’s commands… But if you learn to change directories (cd); list files and their attributes (ls); and change file modes and attributes (chmod) then you’ll get done!

  Scream if you need any additional help pand information - though of course, google is your best and first friend… Though I’ll see what I can do about checking back here often enough to respond if necessary…

  ~Menageryl