Service problems with wdtv live hub

Hi can some one help me please.

My wdtv live hub is connected by etherent but my services does not work and causes my wdtv live hub to crash as soon as I try to open youtube for example. It also crashes when I want to play a trailer from the options menu for a video. I use the services for youtube, crunchyroll and to watch trailers for my new movies which I add on.

Things I have tried are trying to update firmware (already have latest firmware) resetting the wdtv to factory and resettig the services account. Changing ethernet connection to different ports on the back of my hub. All doesn’t work.

Done a connection test everything seems fine with the green ticks. When I put a new video on my media player it automatically grabs the info and images from the internet so it is connected. I have a BT homehub 5 and I remember my wdtv working at my mums when I played a trailer from online at her house so I dont think its the wdtv hub?.

Anyone got any idea what is wrong as I cant see what is wrong? Maybe its some settings for my BT hub? Because when I connected my xbox one I also had problems loading certain things and had to open the internet explorer on the xbox and click start browsing after I set the parental setting which I notice I have to do when I connect every device such as ipad, mobile, laptop to the homehub 5.

Thanks in advance for any suggestions and help.

Are you able to test the device on a different connection?

Have you tried rolling back to the previews firmware? Does the unit make any changes?

1 Like

I managed to solve my problem. I cannot believe what the problem was! After hours of downgrading the firmware one by one (about 5 different firmwares) and not seeing a result. I also disabled the smart setting on my hub which is the settings which you have to choose your parental controls before surfing the net on BT homehub 5 on any new device. I decided to plug the HDMI into the back of the TV. (Running out of HDMI sockets in TV so have plugged the WDTV into my xbox one HDMI input) anyways it works fine now after all that!

So for anyone that has the problem of the screen turning black once trying to select a service to use. Try connecting to a different HDMI socket or use a different HDMI cable. May work. I plugged it back into my xbox one and it didn’t work but fiddled with the wire on the back of the WDTV, slowly wiggling it out until it worked. Now just make sure I don’t touch the wires and my wdtv live hub working fine on my xbox one. Will try buy a new HDMI cable and see if that fixes it completely or a HDMI switcher so I have more HDMI sockets in my tv.

Thanks Help4All for your reply, was going to try a different connection today but now it’s fixed. Happy again!

Better make sure any HDMI switch you get has an external power supply!

1 Like

Thanks for the heads up flhthemi. Was about to buy one from ebay without external power supply. Lucky you gave me the heads up.