Self-assigned DHCP, access via Finder, but no QuickView

Hi there,
I have a MyBook Live that i use via ethernet directly connected to my computer (via Thunderbolt). That’s slow, but usually worked. I wanted to check for updated firmware, so went about to set it up via my router. However, the green light at the front is continuously blinking, even after 20 minutes.
Then I went back to Ethernet, and had the same problem there. The interesting thing is that I can connect via Finder, but not via QuickView.
I also cannot use the Timemachine Backup segment, as it won’t let me connect to it.
Anyone got an idea of how to fix this (new ethernet cable is on the list, but seeing as I can connect, I’m not sure if this is an issue), what to do to get quickview back and to connect via the router?
Many thanks for replies in advance,
(El Capitan 10.11.6)

The unit has not been tested for Time Machine or WD Qucikview functionality while connected to an adapter. You may be experiencing a compatibility issue.

Thanks Trancer. It worked initially (both quickview and connecting via finder), but I guess that it may be an on/off thing. Any idea why this would happen when I try to connect via the router, too?
I’ve upgraded in the meantime to Sierra 10.12 and haven’t tried it since.

It should work normally since the unit was meant to be connected to a router via Ethernet.

HI and thanks again for your reply.
I managed to set it up via the router, but it won’t let me install the quick view software and the MyCloud registration doesn’t work either.
How weird. But I can get to my files, that’s the most important bit!