Select Content Source: Windows Shares --> hourglass forever

Trying to get my WD TV Live to connect to shared folders on Windows 7 PC - when I try to connect a Windows Share, the spinning “hourglass” (arrow chasing its tail) runs indefinitely until I cancel. I can connect via the Media Server connection method, but that plays back almost no file types (video) - no mkv, mt2s, etc. Any ideas? I’ve tried fiddling with networking settings on both ends, rebooting all devices, googling for hours, but haven’t seen anyone mention this symptom.

Check if this link helps.

Thanks for the reply, but I don’t think that applies since I’m trying to connect to a Windows 7 machine, not Mac.

I have the same problem - it will not ‘see’ my Windows shares anymore, I have a few - 3- PC in the house, all running Win 7, all with shared folders with either music, videos, movies or  photos. And none of them show up… well I should say that they will pop up sometimes on the screen for a second or two - and boom they’re gone again.

I have Netbios over TCP on, static IP on 1 PC, DHCP on others.

It worked for  a week or so, then I got a message that I had to reconned again, or simlar message.

I am thinking… could it be my router - I have a top of the line E4200 Cisco, runs great.

By the way my shares are visible to all and from all my other computers…

I did install the newest fimrware yesterday  1.07.15

Any ideas ?

Set your E4200’s workgroup to something different than the rest of your computers.

I had the same types of issues with my E3000’s and that did the trick for me a long time ago – never had another issue.

This type of thing has been discussed on Cisco’s various product forums for a long time; Cisco seems uninterested.

Sorry but it still no longer works - my shares keep disappearing again…

This is crazy. I did turn Homegroups and the 2 related services…

I’m ready to return mine. My WDTV has had this issue since I bought it, and none of the firmware revisions have fixed it. I can connect to my windows media server just fine, but connecting to a windows file share (Windows 7, homegroups turned off), only works for a little while, before the WDTV forgets about it, and can’t sign in any longer. The WDTV is connected wired to my server, going through 2 ethernet hubs on the way. Rebooting the server doesn’t help. I do have a Netgear router on the network, I’m not sure what it’s workgroup is. I’m super annoyed. I’m about to get online and trash this piece of S to every forum I can unless I can get some help here. (whine)

Yeah, that’s good…  I think you’re better off returning it for something that’s even simpler to set up.   Good luck with that…

AngryAtWD wrote:

 I’m about to get online and trash this piece of S to every forum I can unless I can get some help here. (whine)


Its no good coming on here with threats. This is a user to user forum and we really are not concerned what you write about the player plus of course you will not be the first! 

I get this problem as well, no idea why but what works for me is:

Go to network settings,

workgroup name - don’t change anything, just click on submit, you get a message saying “network restarting”

Then my PC shows up on network share.

Using win7 btw.

1 Like

I do this too -  but it works only 1 out of 4 times…

For now, I have copied my files to a little external HD and it’s connected direct to the WD LIve, a work-around. I am hoping WD will eventually figure out the mystery of the disappearing shares…

I called today WD  - the tech said I should try a Linux share to test - as I have a Ubuntu PC I will give it a shot, if this work it really means there are some issues with Win 7 advertising its shares.


I have to say that I am disapointed by this box so far too. Not only do I have this issue but the one where the netflix password keeps being reset.