Security certs errors

help. ok so i am new to the my cloud. i bought myself a 3tb. i am fairly decent with networking to a extent. i have a cisco e2500 running shibbys tomato 1.28 latest version. i have my cloud set as a static ip. i have ports set to forwarding on 8080 80 and 8443 443 as it showed in a linksys document for my cloud. i can access it from my pc web browser (chrome no issues) if im out side the home i get a error saying my connection is unsafe. i also get promted for installing untrusted certification when using the my cloud desktop app. i have followed the document i found about adding the cert to trusted users. im on windows 8.1. still no matter what i try on my home network with the app iget the prompt to to continue yes or no ir view cert. and still from off my network i get the unsafe connection message. its kinda defeating the purpose of what i bought this for. i wanted to share documents between my family. my mother in law and brother inlaw both are getting the unsecure messages as well. ones windows 7 and ones mac. im so lost i have enabled ssh on the my cloud as well. anyone have anyclue how i can get this working right. 

See if putting the cert into the LOCAL MACHINE\TRUSTED ROOT CERTIFICATES store helps instead of the user level.

i probably should of said i tried that lol…i tried user i tried local. i even download the cert and manual installed it as well.from besides the prompt.on my end i dont know if its 8.1. but as i said my inlaws are on 7 and brother inlaw on mac. they have issues with wd2go as well. i just find it strange my self am getting it with the app it self. (my cloud). and the ports are forwarding. its says connected in the ui. i set a static ports forwarded as well. all shows woking in ui. i feel like its on wd end. tried internet explorer , tried chrome. same thing. 

i should add i did the manual way as well. by access mmc.exe and changing it to all for the cert. still same thing. 

Thinking about it, I don’t know if there’s anything we can do.

It’s a wildcard cert for *.device?  The hostname needs to match what is in the cert.

I tried updating my /etc/hosts with a dummy hostname within a sub domain name.  I was able to connect to My Cloud on my internal network, but I still got the cert error.

My home domain is not, so it looks like the cert might only work properly is set up from an external connection (something weird that WD does on their web interface?).

From my understanding, the MyCloud app doesn’t touch your IP directly, it goes to WD’s site, then that forwards to your device.

If you are trying to hit your device directly without using WD’s web interface, then you might have to replace the certificate.

In short, the host name in the cert has to match the host name you are connected to.  So if you user https://, the cert will fail.

Also, this is a self signed cert, so I don’t know how ‘stable’ it is.

If you really wanted to get fancy, I guess you could log into the console (SSH), regenerate a cert, and append hostnames to the cert.  That way it will work with WD’s site and a hostname that you choose.

i dont have a problem driect connecting ip wise i set mine to static set ports 8080 80 8443 443 connecting with that its perfect. but throught the my cloud app on home its **bleep**. same out side at the other 2 locations…