Sd card format tool

I have a 64G SD card that I think needs formatted from exfat to fat32.
WD has a program but it requires an SD card reader to work. I’ve seen other brands that are free and wonder if it will be the same rather than working with the card in my tablet. I can see the safety of not formatting my tablet instead of the SD card. The card works formatted for external use but not internal memory.

My desktop file explorer sees the difference of the SD card, but right clicking doesn’t show property options. It’s like a read only that I shampooed and can’t do anything with it.

You don’t need any SD card formatter tool despite having a computer. There are a lot of ways on your computer to format the SD card. This article can tell you different ways to format your SD card with NTFS / exFAT / FAT / FAT32 using Command Prompt and in-built Windows tools.

Thanks but a diskpart / list disk shows only detail or sizes of my computer drives. I think I need to use a card reader.

1 Like

I should add that even using it in the external or portable setting, it shows ejected and I have to mount it to see it in the tablet. Bad card? I may try a 32GB card for its format.

AFAI understand you don’t have access to a computer with SDcard slot or an SDcardReader-to-USB I/F. If so, you need a computer (friend’s, a shop’s etc.) with SDcard reader/slot or an -say- USB I/F.
After that you can use Windows’ diskpart or other Windows utilities:
Tuxera SDCardFormatter: SD Memory Card Formatter for Windows/Mac | SD Association or HP download sdfmt3_1
Panasonic SD Formatter: Application Panasonic SD Formatter
P.S. There gotta be SDCard utilities for MACOS or Linux or etc. OS.

Thanks, I have a SD card reader but it’s dead and the USB too though plugged in.
I tried formatting internal again with the tablet and it looks good perhaps until I restart it or something tries to use it and gives me a corrupt message.

So over night it got corrupted, or wants reseated. Internal won’t work.

I tried my SD card in a friend’s smart phone and it saw a problem with it and fixed it. It didn’t show details.
Thanks for your help.

1 Like