Screen going blank after about 10 seconds

Morning.  I got my WDTV+ about 2 days ago.  I’m running it on a Philips HD TV (model# 47PFL3704D/F7).  Sometimes the WD will boot sometimes it wont.  When it DOES boot I get the WD boot screen then the main menus.  About 10 secs after the menu comes up the video shuts off and I lose the picture.  WDLTV+ is defaulting to 720p which my TV supports so that is not the issue.  When it wont boot all I get is the flashing power LED signifying a diagnostic error.  I’m running Firmware wdtvliveplus_1.06.16_B downloaded directly from this website.  I’ve tried turning off the WD for 10 minutes and that’s when it will normally come up.  Also, I’ve double checked to make sure it’s in NTSC mode.  Any help would be appreicated because I have not been able to use this unit one single time.  Thanx in advance!


Can you try this in another TV set? Just as test.

Also, if you are using the auto output option, change that to manually and select the best resolution that your TV set support, this might help you.

no other TV.  I called WD tech support and explained everything I’ve tried.  I’ve gone through all the steps they would have had me do anyway so I guess it’s bricked.  So, back to the place I got it for a replacement.  MAYBE the next one will work properly.  Thanx for the help.