Save file to my cloud dl4100 using app on android

Using the My Cloud remote app on a PC no problem. I can download open close create & save ok. The problem I am having is when I try that on an Android tablet. If I create an excel or similar on the android when I ‘save as’ I can’t find the file path to the My Cloud. Any suggestions please.
About 6 months ago I’m sure I tried this on a mobile Android and it worked OK. Tablet is Samsung & so was mobile. I will try a mobile again while waiting for feedback from forum.

Is this happening only with said files in particular? Are you able to copy the file from your phone after saving it to it first?

Thanks for the interest Trancer.
At the moment I am trying to Save created documents such as excel,word and photographs etc to go to dedicated files on the My Cloud DL4100 so that only certain users can be allowed access. I don’t want to use the Public option for this to happen. At present this is being attempted on a Samsung Tablet. I haven’t tried saving to the tablet then copying yet but will try later.