Samsung UN46D8000 unable to Detect MBL on wireless

Just received my MyBook Live 3TB NAS yesterday and tried it on my Android Tablet, iPad, Android SmartPhone and Wife’s iPhone, Windows 7 computer and everything worked great. Was able to access the storage with Wifi via IP Address, DLNA with Windows 7 and using the W2Go application on the apple devices.

I then tried to get my Television to detect the device, this is where the headache came in. So as I said, everything seemed to be working right out of the box, but my Samsung TV wouldn’t detect the device even though the Wireless signal was connected and I am able to watch Netflix on the TV.

I try to search for the device by switching difference sources, and it doesn’t find it. When I switched it over to a wired Ethernet cable, it shows up right away and the Twonky Server was being picked up. As soon as I disconnect it, I am unable to find it again.

I’m not sure what the problem is and I hope someone can help me out. I have a FIOS Router that the MBL is connected to, it’s using a older firmware because I tried to upgrade it to the latest one and that proved the same results. My TV is connected to the wireless signal off of the FIOS Router.

Please help, I am so excited about the MBL and would like to get it to stream wireless with my TV, if I have to I’ll end up using a hard wire, but for now I would like to avoid it since I would have to pull another cable through my wall and it has a center stud dividing the wall into two sections.

Thanks you all your help and hopefully this frantic posting makes sense.



Have you tried resetting the devices Router, MBL and TV?

Also, check the firewall settings for you WIFI to see if everything is ok.

If the MBL is working with all the devices, it might be something on the configuration of the router wireless or the TV settings.