Same problems persist with 1.04.17

I just tried the new firmware 1.04.17_B for the Live Plus, and for me, I am having the same problems that I had with 1.04.10. My biggest problems:

  1. The VOB stuttering and audio dropout issue is still there. If you select the VIDEO_TS folder, then select ‘play’ or ‘enter’, DVD menu navigation works, but the video stuttering and audio dropout problem is there, just like it was in the last release. However, if you press ‘play’ on the VIDEO_TS folder, then the video plays OK (no stuttering), but DVD navigation does not work at all (you can’t select ‘Menu’ in the Options menu). So you can either have stuttering with full DVD navigation, or no stuttering but no DVD navigation. Neither one is acceptable!

  2. The box powers up with the HDMI resolution set at 720p, which my TV does not support. (This would be OK if the WD box would remember the video settings that I manually set). 

  3. The box does not remember the video resolution settings that I manually set. I go into the WD setup menu and set the hdmi output to 1080i. However, after powering the WD box off/on, the WD box boots up at 720p.

  4. The box does not remember the color space settings that I manually set. I go into the WD setup menu and set the color space to RGB Low. However, after powering the WD box off/on, the WD box boots up set at RGB High.

Try the new firmware release, it might help you with this issues.

oxter wrote:

Try the new firmware release, it might help you with this issues.

And then again probably not.

richUK wrote:


oxter wrote:

Try the new firmware release, it might help you with this issues.

And then again probably not.


Unfortunately, I think that richUK is right. Even if 1.04.18 did fix those issues (which is extremely doubtful), the firmware release has issues that are even more serious. 

I did not actually try version 1.04.18 because the release notes only listed two changes that had nothing to do with the problems that I listed above. I had tried versions 1.04.10 and 1.04.17, but the problems were still there. I did not want to go thru the upgrade/downgrade process again for nothing.

In addition, I am still using 1.03.49 because the newer firmware versions give me the VOB stuttering issue, and the no sound with Netflix issue. I would rather use 1.03.49 and have no stuttering and have Netflix work correctly. Flingo and all the other junk that is in the new firmware releases have very little value to me if the basic function of being a media player does not work!

oxter wrote:

Try the new firmware release, it might help you with this issues.

Have you read the thread announcing firmware version 1.04.18? The same VOB stuttering problems that existed in 1.04.10 and 1.04.17 are still there. On page 3 of that thread, Community Manager bill_s said ‘We are working on the stuttering issues.  Hopefully, they’ll be resolved in the next release.  No promises though.’…so he is acknowleging the problem. Why would you think that the new firmware would help?

The other 3 problems that I listed have been present in all firmware versions (Beta and official) since I purchased the unit in August. These problems have been there with 1.03.29, 1.03.39, 1.03.43, 1.03.49. 1.04.10, 1.04.17, and 1.04.18. For 6 months now, the WD box has been powering up set at 720p. My TV does not support 720p. I go into the WD setup and manually set the video output to 1080i 60Hz, and RGB Low. Then, when I shut off the WD box and turn it back on the next day, the WD box has set itself back to 720p and RGB High. Why doesn’t the WD keep the video settings that I set manually?

I have posted this before and I hate to sound like a broken record, but… I do not understand why this problem is so hard to fix. If the WD box is set to HDMI (auto), the box should try to do auto negotiation/handshaking with the TV and set the resolution/frequency automatically. However, when the user sets the HDMI video output manually, the WD box should remember this setting and simply set the video output the same way when it powers up. No negotiation/handshaking should take place when the video output is set manually. The reason that people set it manually is because auto negotiation has failed. It seems like WD is spending a lot of time trying to get hdmi handshaking / auto negotiation working with all TVs instead of implementing the simple fix of just leaving it set manually to the previous setting.

When I got my satellite TV box, I used it’s setup menu to set the video output to 1080i 60hz. After that, it stayed that way! It does not change the video resolution and colorspace value every time I turn it off and on again! The same is true for my dvd player, blu-ray player, game system, my computer, or any other device that you can think of. Once you manually set the video output, it stays that way. The WD box is the only device that does not remember the video settings!

If the WD box would remember the video resolution/frequency and colorspace value when it was powered off/on, it would not matter if HDMI handshaking did not work (because you could set it manually). If WD would implement this simple fix, it would solve a lot of problems!

Yes,  I have, but as other WD TV owners, I do not have this issues, I can stream VOB files without stuttering. Now, trust me, I understand how you feel, I had issues with the WD TV in the past.  I am an early adopter, I bought the WD TV Gen 1 the first day it came out, and I have done the same with each WD TV model release, but the Gen 2, up to the WD TV Live Hub.  Normally I use to update the firmware as soon as it is released, and I have encountered many of the problems described in this forum.  It was just a suggestion, because for me, this firmware have not affected any of the functions of my WD TV.

Lucky me?  :dizzy_face:

Thanks for the reply oxter. Now I understand why you posted that. I am sorry if my post sounded negative, but after six months of going through this procedure (almost every day) I am getting a little jaded.

  1. Turn on the WD.
  2. **bleep**, I can’t see the video because the WD box has set the video output to 720p.
  3. Switch the video cables to the composite output so that  I can see the video output of the WD box.
  4. Go into the WD set up menu and manually change the video output to 1080i 60Hz, RGB Low.
  5. Switch the video cables back to the HDMI output so that my TV will run at 1080i 60Hz, RGB Low.
  6. Everything, including Netflix, works correctly at 1080i 60Hz, RGB Low (as long as I use firmware 1.03.49).
  7. Turn the box off. Next day start over at number one.

BTW, I am happy to see that a moderator here is actually trying to participate more in this forum.


have you checked whether there is a firmware upgrade for your TV?

I ask because it is strange that it does not support 720p. 720p is used by some TV stations. If you had a digital satellite receiver and if you received such a station, your receiver would have to convert  720p to 1080i, i.e. it would have to interlace videos that are not interlaced, but progressive, and convert them from 720 to 1080 lines.

Moreover, 720p is one of the standard Blu-Ray formats.

HorstM, I have an older Panasonic Plasma TV. There is no firmware upgrade for my tv and my tv does not support 720p. It does support 480i, 480p, and 1080i. It also supports a lot of computer standard modes (800X600, 1024X768, 1280x1024, 1600x1200, etc), and it also supports HDCP copy protection.

I have a satellite receiver and I have set the receiver to output 1080i 60Hz. Yes, the satellite box is doing the scaling. I have Dish network for satellite. Their boxes do no have the ability to pass-thru the native video resolution of the source material. You have to choose a specific frequency/resolution.

Regardless of what modes my TV supports, I when I go into the WD setup and manually set the video output to 1080i 60Hz, and RGB Low, I expect it to stay set that way and not decide all by itself to change the output to 720p (the only resolution that my TV does NOT support).

oxter wrote:

Yes,  I have, but as other WD TV owners, I do not have this issues, I can stream VOB files without stuttering. 

You’re going to have to back this claim up.  If you are playing over a USB thumb drive then conversation over.  But, if you are streaming over a network then you are the only person to not expereince VOB stutter when using the DVD menu feature.

So, if this is the case, please explain your setup to help resolve this issue.

Nehptis, you need to bear in mind that for each person that complain about this issues, there must be hundreds that do not encounter the stuttering VOB’s.

As for mine setup, you will be surprise how simple it is:

A Thomson wireless router (sorry, I can’t remember the specific model as I’m REALLY BAD at remembering model numbers)

A DWA-131 (thou I prefer to connect the WD TV Wire )

Now, I have lost of files in mine computer, Using Windows 7 Ultimate Edition. Also, connected to the router I have a Switch, connected to the switch I have :

1- Three  Xbox 360 ( I know It looks like a lot…)

2- WD TV Live

3- WD TV Live Hub

I have ripped movies and I can stream them to the WD TV without a problem. As stated before…I have encountered many of the issues reported in this forum, but VOB stuttering, is not one of them.

Are you playing the movie thru the DVD menu? Meaning clicking ok on the Vob file instead of clicking play. Play works fine. Vob thru DVD menu stutters. Also what app did you use to rip the DVD? Your network setup is pretty typical. I am on a switch via a router with a wired network streaming from a wd ext nas drive.

The really strange thing about the VOB stuttering problem…If you get the exact same VOB files (from the VIDEO_TS directory) and encode them into an ISO), the ISO file plays back normally without stuttering (while using DVD navigation). I was thinking that it might be because the WD box only has to deal with one file when playing the ISO, but has to deal with multiple files when playing the VOBs…but I am just guessing.

Sorry for the delay…

I’m playing them through the DVD menu. I use DVDFab to rip mine DVD’s.

I also use DVDFab to rip the DVDs to the hard drive in my windows XP computer, and I have the VOB stuttering problem…so it appears that the ripping software is not the problem.

I agree, not ripping related.  But, I also agree most likely multi-file VOB related vs. single file ISO.  Meaning the recent firmwares have somehow introduced a stutter issue when traversing the multi-file VOB package.


Can you give us some insight into what tech support is able to reproduce on their end with the VOB stutter issue?