Safe shutdown

I did not and neither did WD’s support people. I don’t think I should have to rely on a different interface to shut it down. Poor firmware design.

Yes it is poor firmware design and very poor quality control/beta testing of that firmware that they didn’t catch the fact there isn’t a shutdown button like there is on the v4.x firmware.

However, it is a simple matter of creating a batch file on one’s computer to send the shutdown command via SSH to the My Cloud to shut it down or to reboot it. One, if using Windows, simply double clicks on the batch file and it will trigger the shutdown on the My Cloud. There are even mobile apps one can use to send the shutdown command. As mentioned above, I use an app called SSH Button on my Android phone to issue the shutdown command. Makes it really easy to shut down the My Cloud without having to access the Dashboard.

You give up to soon!
There is a small and simple utility called WD Accesses I use daily to turn on and turn off.

see link
http://supportdownloads.wdc.com/downloads.aspx?lang=en&fid=wdsfMyCloud

1 Like

Looks like this tool came out a week after I returned my unit. Maybe they really did escalate my ticket to the next level.

Does this mean that wake on lan is enabled on this device?

RAC

No. The Wake-On-Lan topic has been discussed previously. Currently the single bay My Cloud doesn’t appear to support the feature. The NIC hardware has to support that option and it doesn’t appear it does. Here are just a few prior threads discussing the issue, do a search for others.

I was talking about the gen 2. How can the WD accesses turn the My Cloud on? Of not
wake on lan. Does that mean it will turn on a gen 1 My Clloud?

RAC

My guess is that much like the Gen 1 My Cloud, one cannot turn the Gen 2 My Cloud back on with WD Access once turned off. In one of the links I provided above a user of a Gen 2 My Cloud dumped the info from the NIC and it indicated wake on lan was not supported.

The WD Access program doesn’t have the option to turn the Gen 1 My Cloud back on once turned off as evidenced by the two screen captures below. First screen capture shows the option to Shut Down, the second screen capture shows what options are available once the My Cloud is shut down. The only solution is to power cycle the My Cloud to reboot it.

Tulak What model are you turning on and off?

RAC

rac8006
I use
My Cloud Mirror 4 TB
WDBZVM0040JWT-NESN

I use a batch file now to shut down but for months, I just shut off the power strip it was plugged into with not one problem at all.

The single bay My Cloud and the My Cloud Mirror are two different devices with different features and possibly different hardware. Supposedly, if this post is correct, the Mirror doesn’t support Wake-On-Lan, but the EX2 does. Per that thread (in a following post) the Mirror can be “woken up” somehow.

Obviously when the single bay My Cloud is shut down it still draws power as the back LAN port is still active. Does this mean there is some way to wake the unit up after triggering/issuing the shutdown command? Don’t know. Would be nice if there was.

Bennor
As I sad My Cloud Mirror with WD Access software I am able wake up and turn off.
As you pointed out yes “My Cloud and the My Cloud Mirror are two different devices” old and new!

Here is my setup: My Cloud Mirror is connected to router with Ethernet cable same is router and PC.
Even before when router and PC was running WI FI it worked too.

Using a gen 1 My Cloud connected to a broadband gateway on the local network.

The inability to “wake up” a single bay My Cloud has been discussed in the past in several earlier threads as mentioned above. Its an issue that comes up from time to time. While the Mirror may have the option to wake up the My Cloud Mirror, currently the single bay My Cloud units do not. Currently the only way is to power cycle the single bay My Clouds. Don’t recall if anyone with a 2nd gen single bay My Cloud has indicated if the wake up option in the Mirror is also present in the 2nd gen units. All I’ve seen is the NIC info dump mentioned above that someone else did from a 2nd gen My Cloud that indicates the WoL option is not present on the NIC.

I connected to my My Cloud via SSH. Unfortunately I don’t have a shutdown file in my /sbin/ folder. All I have is /usr/local/modules/script/shutdown.sh Any suggestions?

The above directions for using SSH to shutdown or reboot the My Cloud are for v4.x firmware My Clouds. Unknown where or if there are similar commands to shutdown/reboot the v2.x My Cloud units. There probably are similar commands for v2.x versions, but since I don’t have a v2.x My Cloud I have no way to find out.

As indicated above, one can use the WD Access program (http://supportdownloads.wdc.com/downloads.aspx?lang=en) which does have the option (at least for v4.x versions) to shutdown the My Cloud, see my post above on Feb 16 for screen captures indicating that.

I tried to execute that shutdown.sh file and fortunately it works! So if anybody wants to shutdown a v2.x WD My Cloud you could use that command. I’ll try that WD Access program although I actually need a possibilty to shut it down from a mobile device!

If only it had WOL functionality. I’m probably going to buy a remote power socket and do it as follows:

  1. Use SSH to shutdown device.
  2. Use remote to disconnect it from power.
  3. Use remote to connect it to power and it hopefully will boot!

EDIT:
WD Access for Mac has no shutdown functionality!

My system with the latest version of 4.x firmware has /sbin/shutdown and /sbin/reboot and /sbin/halt

RAC

Yep, as Bennor already said: the above instructions are only for the slightly older Generation 1 with v4.x F/W.

Thanks for the suggestions, WD Access allows me to shutdown the device. Not perfect as this should be in the we UI but it works.