Safe shutdown

the second workaround “found” by Pogmog is the shutdown via script executed in the webbrowser.

So , the script should be:

// @include [the IP of you WD cloud]
‘display’: ‘inline’
}, 5000);

Is that right?
Do you use Greasemonkey to create and execute this script?

thansk for the feedback

1 Like

This is great, and WD Quick View works on some of the devices. WD Access also works on some. However, you have to be running a computer supporting these. Finally, I’m looking for a way to use some kind of a script to SAFELY shut down my Clouds when we are running on backup power. It’s hard to schedule power failures for only when your at the computer.

1 Like

Is a shutdown this way really completely SAFE? I have already lost everything on one WDMyCloud because of a power failure.

1 Like

Cannot speak for others but I’ve been using SSH to shut down my first gen v4.x My Cloud for more than a year now every night with NO problems and NO loss of data.

The Shutdown option within the Dashboard is the official WD method of shutting down the My Cloud (or putting the My Cloud into hibernation mode).

However, if during the shutdown process your My Cloud looses power there is no telling what will happen.

1 Like

Hello. I too am having trouble trying to safely turn my machine off. Using Linux Lubuntu. I see most of the programs you need to download are for Windows and Mac, I couldn’t find the Linux option. I don’t know anything about script solutions, no idea where to begin. When I try typing in javascript:dev_shutdown() in the search bar of the admin page, it just does a google search. I don’t know where to begin with an SSH-Client, or things like: “/usr/local/modules/script/ -h -P now”, what do I do with this? Is this quick view available on Linux? I have to say I don’t think I’ll be buying anymore WD products again, thank you for any help I really appreciate it, if you decide to respond can you start from the very beginning with a step by step guide. Been spending ages on this. Thanks again

1 Like

Hello all,

The following are instructions on how to install a user script manager and the custom script I put together that makes the hidden button on the My Cloud web interface visible. Setting up a script manager and installing a script should be quick and easy.

It is basically as follows:

  1. Install a user script manager. This is just a browser add-on that enables the use of custom-made scripts. It is the same process as installing any other add on (like an ad blocker). The process is detailed here, there is also a list of user script managers for different browsers. Because I use Firefox the script manager I use is Greasemonkey. On Chrome you would likely use Tampermonkey.

  2. After you have a user script manager installed the next step is to install the script. The custom script for un-hiding the hibernate button can be found here: WD Un-hide “Hibernate” Button Script. This will add the script and should enable it automatically.

  3. The last step is to tweak the script to suit your set-up. In your browser’s menu there should be an “Add ons” button, and then once you’ve gone into that a section called “User Scripts”. Once there right click on the “WD Cloud Unhide Button” entry and select "edit". The only thing necessary to change is the IP address of the WD My Cloud. You can find it in the address bar when you access your WD My Cloud web interface. Once you have your unit’s IP address you need to edit the script. Change the line “@include" to your own address. For example, "@include”. Once this is done, the script should be properly configured. Simply save and all is done.

And that’s all there is to it.

1 Like

Just got off the phone with support. REALLY! There is no shutdown button, even though she had me look in both obvious places.

The answer? Just unplug it!

WD fix this!

1 Like

Since this issue was first raised in Jan 2016, and nothing has been done about it (even though the missing control has been located by users in the Dashboard website code), I think we can safely assume that WD’s arses are planted firmly on the sofa on this issue, and you’ll have to look into the user-provided solutions for a fix.


Hi all,

I am the happy owner of a WD My Cloud Gen 2, with latest firmware 2.30.165.

I think that using “Hibernate” hidden option from UI Interface (alias for /bin/sh /usr/sbin/ comand) or simple “halt” command is WRONG. After I run the command and even ALL leds are off (front led and NIC led) the NAS is still “working” and I can hear some noise inside (You have to put your ear close). It’s like the HDD is spinning, maybe is not properly shut down. Moreover, with all the lights off, the smart plug/socket to which the NAS is connected shows me a 5 Watt consumption. Can someone confirm it?
WD is trying to hide a design flaw.

After “Shut Down” selection from “WD Quick View”, or after “/usr/local/modules/script/ -h -P now” (or “/usr/sbin/ -h -P”) or “halt -p” command the smart plug shows 2-3 W consumption (all leds from NAS off). A little better … :slightly_smiling_face:. Here it’s not about Watts but who knows what he does in the back. Powered on with wdmcserver, wdphotomergerdb & twonkyserver running/scanning/indexing the NAS use around 8 W.

Conclusion: What is the command to turn OFF the cloud ? 0 Watts consumed.
Meanwhile I ordered a “SONOFF Wi-Fi Wireless Switch” (5.5$) that will fix the BUG (+ WOL option). Shame WD! :thumbsdown:

P.S. This is the real reason why the shutdown / hibernate option is hidden in the Dashboard menu, because it can not be stopped. Perpetuum mobile :grinning:


There isn’t one. The MyCloud does not have a PSU that can be turned off, or put into a standby mode. The hibernate or shutdown commands from the Dashboard only shut down the HDD and halt the OS (in my experience, anyway). To reboot, or to reduce the power to zero, you have to unplug (hibernate is a misnomer, IMHO; shutdown is a slightly better name).

The shutdown command is intended to cease all disk activity in order to perform a safe power down by removing the DC power.


The My Cloud remaining on after issuing a shutdown or halt command is one that has been discussed/commented on in the past. On the first gen My Cloud after the front LED goes off after shutdown the back NIC LED’s remain on indicating that there is still power flowing to the back plain the hard drive is connected too.

Apparently a similar thing happens with the second gen My Cloud units as well based on past discussions.

Its entirely possible, due to how the My Cloud operates, firmware running in RAM or a RAM drive or similar virtual memory storage location, that a shutdown, hibernate, or halt doesn’t fully power off the hard drive. Its just one more quirk to add to the long list of quirky things with the My Cloud firmware/hardware. If one takes a look at how the firmware is coded/mashed together, they’d see it looks like it was (in some respects) cobbled together by monkeys. The messy firmware is something that’s long been complained about since it rears its ugly head from time to time.


My cloud has 2 weeks. The firmware is updated to v2.30.165 and I have spent several attempts for wd to tell me how to turn off my unit. The last response from your technical service is: … WD Access will not offer the option to close because the MY Cloud device does not have it, it is an option that only appears in upper / posterior devices.

To turn it off, you must manually disconnect it from the power cord … The past has returned …

1 Like

Have you seen the following WD Support document?

Please note that most people here on this support forum are users such as yourself who came here for one reason or another and have stayed to help others. If you want to talk to WD Support then contact them directly.

Yes. To turn off power to the single bay My Cloud units one has to remove the power cord from either the wall or the My Cloud unit. The My Cloud is designed to be left on 24/7.

This issue of a lack of a Dashboard shutdown for the v2.x single bay My Cloud units has been well discussed in this subforum. You can find many past discussions using the forum search feature, magnifying glass icon upper right. Several of those past discussions (including this current discussion) explain how to use SSH to issue the “halt” command to cause the My Cloud to enter hibernation mode.


I meant that I already spoke with WD support and the answer is the one I put and that matches yours. The WD Support document as the reference already read and also talk about the option ibernación that does not exist in our model. Luckily in other forums like the ones that say talk about how to turn it off with ssh because WD Support does not provide much more help from their product.

1 Like

There may be a problem in translation here, but, to be clear:

Bennor is not WD Support, and does not work for WD.
I am not WD Support, and do not work for WD.

It is very rare for anyone from WD Support to respond on these forums.


You indicated previously you tried WD Access. But did you try WD Quick View as the WD Support How to Shutdown a My Cloud Device document also indicates?

WD Quick View for Windows:

WD Quick View for Mac:


Not able to post link in the answer so follow this link for the easy browser shut down instructions

The funny part is they already have this feature in the dashboard utility but for some strange reasons they made it hidden.
so this page provides the bookmark which can be dragged to the bookmark bar of the browser and can be used on the settings->utility page to enable shutdown option.


on the webpage you posted above, pointing on the link to the bookmark it shows
But in your previous post here Shutdown mycloud? the location is

So is the location path on the webpage posted here above incomplete?

1 Like

Thanks for notifying
i corrected the link now

1 Like

you are wellcome.

does this “trick” work on Android devices/mobile webbrowsers? Does it work on Win7/Win10 machines?

1 Like