Returning otherwise good product


#1

I bought a WD Elements Desktop. Tried to install to Windows 7, an HP Touchsmart Dual Core with 8GB RAM. I get an error when trying to install the Smartware Software: “the software has encountered a problem and needs to close.” Tried various methods to install. Later read user reviews on this software and the virtual CD issues, resource hogging, etc. Wish I had known.

I have a 500GB My Book Word Edition (3 years old), a 500GB Re-drive, and two Simpletech (320GB & 500GB) drives I bought two years ago and they install just fine. I originally installed the backup software for those on my old XP computer, but when I bought the HP Touchsmart, I just stuck with the OEM backup software that came with it. I deleted the software from the re-drive and simplechs. I’ve never had any problems with the Re-drive and the Simpletechs, they work great, with or without their original software.

I currently use the simpletech 500GB to backup my Documents files. I could care less about an image backup. I just need data backup.

For HD video storage prior to editing, I want a 2TB storage device. I don’t need backup software. I just want to download videos from my Canon HD camcorder.

I am returning my WD Elements Desktop and will even pay more for a high stroage device that works. WD, I’d stick with you but your software **bleep** and the inability to remove it is bad customer advocacy. You just lost one until you change your bad behavior.

A follow-up to my previous post: While trying to load the software, yes no other devices were plugged into my computer and yes all anti-virus and other programs not needed were closed. Aside from the other issue of the Smartware software not loading, My Computer only recognizes the Virtual CD drive, it does not see the drive itself so I have no way to access even without using the software. I went to Device Manager and yes the SES driver is installed and I have no exclamation points on either the drive or the driver. I went to Manage Devices and saw that although the drive is there, the drive was not initialized. I tried to initialize the drive and I got a message stating that “the drive is locked.”  So, I cannot use the softare to unlock or setup the drive and I can’t use the drive as it appears the software is needed to unlock or initialize the drive.

Second follow-up. 

I think I found the answer for my software error message in the Smartware Software page: "

WD SmartWare 1.4 will only work with Microsoft .NET 3.5 Framework. WD SmartWare 1.4 will not work with Microsoft .NET Framework version 2.x or version 4.x."

I went to Control Panel, Programs, and checked my installed programs and updates. I have MS.Net Framework 4 so it appears Smartware won’t work for me. Now I have to figure out how to at least use the drive without the software as my computer won’t see the drive and won’t let me initilize. I think quicker answer is just go to the store and return. I don’t have any issues with any of my other external drives or included software.

Final follow-up. One reply noted that the Wd Elements is plug-n-play and should not have the virtual CD and Smartware software. I found a thread http://www.fatwallet.com/forums/expired-deals/1047887/m15411019/#m15411019 where there is evidently two types of WD elements on the market with model numbers ending in NETG (like mine) and greener NESN models. With the NETG the models are either made in Thailand or Malaysia. Mine was made in Malaysia. Amazon has good comments on the models ending in NESN with no comments that I saw in a quick review that were Smartware related. Evidently the NESN models are the plug-n-play with no virtual CD and unecessary software.  Anyway, off to Target for a return. I might check to see if I can find a model ending in NESN.

Addendum: Problem solved! Target was good about letting me return the WD Elements Desktop. I went to Best Buy. Tried in vain to find any WD product that did not have Smartware installed. Couldn’t find one. I opted for a 2TB Seagate Freeagent Goflex with USB 3.0. Paid 15.00 more but at this point, it’s money well spent. Brought it home tonight, unboxed and hooked it up. Took 5 seconds for the driver to install. I went to My Computer. There was my Seagate drive with 1.81TB available to me and a folder with USB 3.0 software utility and Seagate Dashboard. I copied the software to My Documents in case I ever want to use the software. I can reformat the drive if I’d like to, nothing is locked. The drive works great. Good job Seagate. I’ve read reviews and know there are issues for some with this particular Seagate drive…what product doesn’t have some negative feedback? However, at least I have something to work with for temp storage while editing.

With Seagate, I was up and running in 10 seconds with a 2TB drive. It runs silent, is vented, has an operation light, and a visual capacity meter. With WD, I lost 8 hours of my life that I’ll never get back, only to end up returning the product, plus 2 more hours of shopping.

WD, please read all of the negative feedback on numerous websites. Why should people have so many issues trying to use your product. It shouldn’t be so difficult. Install software that is optional. What were you thinking?


#2

Elements is a simple plug and play drive and doesn’t have the virtual CD.

Joe


#3

That may be true for the elements SE, but not the Elements Desktop, or at least my version. I’m staring at my box as I prepare to return the product and the box says WD Elements 2TB.

Here’s a link to what I have: http://www.google.com/products/catalog?q=wd+elements+desktop&oe=UTF-8&cid=7511261117971571524&os=tech-specs#techSpecSect7 only my model number is WDBAAU0020HBK-NETG.