Rest call for enabling SSH

I have a small or big problem :slight_smile:

I downgraded my Cloud and now dashboard gets stuck on header and ssh doesn’t work.

The device still works propertly except these two tings.

Can someone tell me which REST request is browser sending to enable ssh? My rest is still working propertly and I want to use that to enable ssh and upgrade firmware again.

For example, in firebug I got for users these request

Please send me the request for enabling ssh.

Thanks in advance

Found it by myself and saved My Cloud from hurt surgery :smiley:

If anyone has the same problem here is the request

PUT /api/2.1/rest/ssh_configuration?enablessh=true

You don’t need api key, just PUT request and your SSH is again working.


After the last couple of times I downgraded my dashboard got stuck on the header and I found that the 40 second reset sorted this, I am sticking with V3 firmware as everything works as it should unlike every V4 firmware I tried that had serious problems with my USB drives.


That also works for me.

Only thing now to figure out is why my btsync is runnig but not accessible from browser and I can happily start using this thing :slight_smile:


I have exactly the same problem. I’m trying to enable ssh, but I’m not very familiar with REST. I tried the following URL:

but I’m getting the following error:

<?xml version="1.0" encoding="UTF-8"?>

    <error_message>User not authorized</error_message>

How can I do the login so I don’t get the unautorized error?

Any help will be highly appreciated

Log in first using the regular url.

What’s rhe regular URL? The dashboard doesn’t work (that’s the main problem I’m trying to solve)

You can’t use a regular browser, as it won’t do a PUT call.  You need to be a little lower-level.

Use Firefox and install http requester plugin

To register yourself send GET request like this

The problem is because I do not know what encryption is used here. I have saved my encrypted password and then I’m sendig that request.

I hope somebody will say what type of encryption is used here.

If your REST api is stil alive(and it is because you get this error) you will be able to turn on ssh and set everything through putty.