Resolution problem - 1080p

Hi, I got a WD TV Live HD (WDBAAP0000NBK-00) and a Benq V2400W Computer TFT.

I connected my wdtv with this monitor with a hdmi cable. First I only got a 720*480 resolution and could not change that in the video settings menu of the wdtv (everytime i tried to change the resolution nothing happened). Then I updated the firmware (there were no error messages) to version 1.04_17V.

I can navigate the menu, and this time i could change the resolution to 720p (and to 1080i - but that resolution looks not very sharp) but i could not change it to 1080p (it told me that my display would not support this, then it asked me if would try nonetheless and NOTHING happened).

My monitor works very well with my computer on a resolution of 1920*1200. I also can change the resolution on my monitor in windows to 1920*1080 and it works very well.

Is there a way for me to use my newly acquired wdtv on a higher resolution than 720p?

EDIT: Just added some linebreaks to make the text more readable.

Use the MONINFO Tool (download here: on your PC attached to that monitor and post the info.

Here is the moninfo report:

Monitor Model name............... BenQ V2400W Manufacturer............. BenQ Plug and Play ID......... XXXXXXX Serial number............ XXXXXXXXX Manufacture date......... 2008, ISO week 38 ------------------------- EDID revision............ 1.3 Input signal type........ Digital Color bit depth.......... Undefined Display type............. RGB color Screen size.............. 520 x 320 mm (24,0 in) Power management......... Active off/sleep Extension blocs.......... None ------------------------- DDC/CI................... Supported MCCS revison............. 2.0 Display technology....... TFT Controller............... RealTek 0x2549 Firmware revision........ 2.0 Power consumption........ Not supported Current frequency........ 74,50kHz, 60,10HzColor characteristics Default color space...... sRGB Display gamma............ 2,20 Red chromaticity......... Rx 0,640 - Ry 0,340 Green chromaticity....... Gx 0,290 - Gy 0,610 Blue chromaticity........ Bx 0,140 - By 0,070 White point (default).... Wx 0,310 - Wy 0,320 Additional descriptors... NoneTiming characteristics Horizontal scan range.... 31-94kHz Vertical scan range...... 50-85Hz Video bandwidth.......... 170MHz CVT standard............. Not supported GTF standard............. Not supported Additional descriptors... None Preferred timing......... Yes Native/preferred timing.. 1920x1200p at 60Hz (16:10) Modeline............... "1920x1200" 154,000 1920 1968 2000 2080 1200 1203 1209 1235 +hsync -vsyncStandard timings supported 720 x 400p at 70Hz - IBM VGA 640 x 480p at 60Hz - IBM VGA 640 x 480p at 75Hz - VESA 800 x 600p at 60Hz - VESA 800 x 600p at 75Hz - VESA 832 x 624p at 75Hz - Apple Mac II 1024 x 768p at 60Hz - VESA 1024 x 768p at 75Hz - VESA 1280 x 1024p at 75Hz - VESA 1152 x 870p at 75Hz - Apple Mac II 1152 x 720p at 60Hz - VESA STD 1280 x 800p at 60Hz - VESA STD 1440 x 900p at 60Hz - VESA STD 1280 x 1024p at 60Hz - VESA STD 1680 x 1050p at 60Hz - VESA STD 1600 x 1200p at 60Hz - VESA STD 1920 x 1200p at 60Hz - VESA STDReport information Date generated........... 02.02.2011 Software revision........ Data source.............. Real-time 0x0031

The really strange thing is that when i boot the wdtv i can see that it uses 720p mode natively (720p 50hz) on the onscreen display of my monitor (it lists the resolution as "720p 50hz), but a short while after the wd logo and right before the wdtv shows its menu it resets the resolution to 1280*720p at 60hz. My monitor shows “nonpreset mode” and calls this resolution 1280*720p 60hz).

I tried to change the resolution to 1080p (50hz) in windows and it worked (the monitor osd shows 1920*1080p at 50hz).

If you look at the bottom, there is no indication of any supported 1080p resolutions. There are supported mode lines for both 480p and 720p… That’s what the WD is going to look for…

On Windows I can select HD resolution (1920*1080 at 60hz) nevertheless. On my PS3 i can use 1080p. It really works. Is there any way to force this resolution with the wdtv? Or to update the edid? If not, then the wdtv is not really usable for me.

Another thing: I get heavy tearing in horizontally panning scenes. Is there a way to avoid this?

EDIT: OK, I solved it. It seems I had to turn everything off and pull the hdmi cable and THEN connect everything together again and turn it on.

Now 1080p and 720p at 60hz and at 50hz work flawlessly! :slight_smile:

Both are visibily tagged as 1080p and 720p (60hz or 50hz) at the osd of my monitor.

Even the tearing is gone (I think this one came with the “nonpreset mode” on my monitor" before pulling the plug).

So it does seem that the info of moninfo is rather useless in deciding if a monitor supports 1080p or 720p.

No, it’s not useless, we are talking about different things. The monitor resolutions displayed by the tool show the refresh rates and resolutions that the panel supports. It does not mean that it cannot playback videos of different resolutions or fps. For example, if you play a 1080p50 video, the panel will display the video, but refresh 60 times a second. That’s better than vice versa, a monitor refreshing 50 times/s only ,while playing a 60fps movie. In additions, some monitors have the capability of switching the refresh rate between 50 und 60fps, depending on the video source, but it’s not always documented. The data that are shown by the tool often are the max. parameters,  meaning it can display up to 60fps progressive, and lower fps rates as well.

Of course, you can force the WDTV to use your favorite video res and fps. Go to Video/Audio Settings, HDMI, and switch from Automatic to the desired resolution and fps.

HorstM wrote:


Of course, you can force the WDTV to use your favorite video res and fps. Go to Video/Audio Settings, HDMI, and switch from Automatic to the desired resolution and fps.

Wrong. I tried that before and NOTHING happened. Only AFTER i made a full restart (turned everything off and pulled the cable) could i change the resolution to 1080p. Before choosing that option did not change anything.

HorstM wrote:

No, it’s not useless, we are talking about different things.

Wrong too. Moninfo does only output the above list. There is nothing about 1080p and 720p support written there. But nevertheless my monitor supports 1080p AND 720p natively. So the tool does not tell in certain situations what output a monitor is capable of. There is a whole section missing in the output above. Moninfo does not report that section with this monitor (“CE video identifiers (VICs) - timing/formats supported” and “EIA/CEA-861 Information”) So please STOP TELLING people that their display device isn’t supporting 1080p and 720p just because moninfo tells so. That is definitely wrong.

wdtvlivehduser wrote:


So the tool does not tell in certain situations what output a monitor is capable of.

Wrong. You mean your monitor does not tell what output it is capable of.