Reseting WD MyCloud 4tb White Case

Is there some secret way to force the system back to somekind of factory configuration.  At this point I dont even care if i lose the original configuration.  When it died the first time, after only a week, I had just managed to get the people I wanted in it as users wth their permissions and folders.  It was set to use a static IP as well.  When it went down, i turned to toehr alternatives as i had no time to experiment.  But it is a rather expensiver device to simoly toss-outt.  I hae tried all the normal resets, the foursecond hold and release and  can occasionally access it it is the only device connected direct by crossover cable to the nic on my system.  On the times i can get in, it is using a briowser going to .  I could once  see the static IP set there and have even tried chaging it back to DHCPC but it always ends up as the “Lost” Ip of  I can see the users and can add new ones but only for a short time as it always disconnects eventually.  Windows will sometimes show the WD MyCloud device in various locations under network devices but it seem to be unstable.

Is there a way to make the unit accwept an update to the new firmware and f so is that going to be of any use?  If it is this unreliable it can;t be used for my needs anyway

what firmware version are you on? if it is the V4 it could explain some of the issues. I updated mine then had to go back as did many others. if you are on V4 and have uploaded a large amount of data it may be it is not actually dropping from the network, just so slow it seems like it

when you get the 169.254.x.x IP address are you coonnected to the router? or your PC? if the PC this is normal as the PC is not a DHCP server. if when connected to the router it could be a cable or router issue

when connected to the router what are the lights doing? Front and the 2 near the network jack.