Remote Device or Resource Want Accept Connection?

My WD PR4100 want accept connections anymore? is it an update to windows 11 or an update direct to the nas drive? If I select network I can see the nas drive which i’ve called dotcom if I select open it want connect it states remote device or resource want accept connection. If I select the other dotcom icon for the nas drive and select view device webpage ie i get this page isnt currently working error http 502. I have tried everything I can think of reset the router and laptop. I’ve tried 2 different computers and still no joy. I haven’t changed anything but it just want allow me to connect and add files etc or check the status of the drive, i know the drive is working as the plex feature is still working and i’m able to view stuff on it on my tv. but i need to add files to the drive, i have tried windows 11 and 10 still no joy help??? if you able to please dumb it down as i don’t know alot about networking i just really need to get it working asap it has been 4 days and i’m getting major grief and well behind.


Do you have OS3 or OS5? Have you tried the sub-forum for your device to see if others are having the same problem? The link below is for OS5, if that’s what you have.
Latest My Cloud OS 5 Personal & Network Attached Storage/My Cloud Pro Series topics - WD Community

On line status,

Hi, do you still have the same problem ?

Mini Militia App Lock