Remote Backup hangning and WD says it's 3rd party

I have a PR2100 that backs up nightly to an Ultra Ex2. Worked fine since I started using them. Remote Backup was recently updated and now the program just hangs while looking for the destination folder. I have installed and reinstalled multiple times and so I opened a ticket asking for help. They suggest I try uninstalling it and reinstalling it and if that did not work then contact the Developer because they do not provide support for 3rd party apps. Which is curious since everything I can find points to WD as the only reference to the app.

So does anyone have any ideas on how to fix this, downgrade the installed version back to the one that worked, or know who the developer is so I can try them?

Thanks in advance

A few of the backup apps seem to have updates that became available with the new OS5 latest firmware.

I see no links to what has changed – I only use the USB Backup app so can not help on the Remote backup app but i did update my copy to the new version

source code folder of the TAR GZ file is still from 11 2021