Remote access

I give up with remote access, the place i bought my device from will take it back as it does not do what it says. Shame as the idea is good, back to a seperate hard drive backup system now.

How are you trying to connect?

There are multiple ways that you can connect to the drive remotely.

Check the link bellow for more information:

How to remotely access a WD My Cloud Personal Cloud drive

How to access files on a WD My Cloud, Mirror, EX2, or EX4 Personal Cloud drive using WD My Cloud Mobile App


I don’t want to connect to my device via your WD apps because the apps are not reliable for me and offer very low performance and speed. 


Accessing from Internet  throught iOS App seems ok unless my MyCloud “autodisconnect” from my network which seems to happennded quite often.

BUT, from antoher PC under Windows 7, it’s ether impossible or very very very slow (I use a fiber connection on the laptop and a goo cable connection to access my home network)

Any clue for erratic disconnections and for the slow or no possible connection from Windwos 7 ?

Thank you

Thanks. I have followed the instructions that came with it, and it is too inconsistant, in fact not much at all now. I have seen it work hence loading everything to it.

Now on my lap top, sit back and wait only to get can,t connect to this device, android phones comes up unable to access device. (0).

My google drive is now backing up my wd cloud drive so i can access when i am out and about and my wd cloud is backing up my hard drive on the home network. Not the best situation.

Yea, I am about through with this unit as well.  THe remote connection (when and if it ever works) is beyond slow.

I have reconfigured multiple times and now I am trying to remote access my drive via my Android App and I get the onld 

Unable to acees device (0).  I have accessed it before and have also gotten this message before.  

Beyond frustrating.

I have been connecting via my iPhone 5, iPad and my MacBook Pro with no issues. I’m using the My Cloud app and VLC on both the iPhone and the iPad. I’m using the My Cloud app and mapped drive to connect on my MacBook.


Inside the network where WDMyCloud is installed, everthing is OK, either 4G / Wifi from a laptop or iPhone (with wdmycloud app)

From the out site :

  • from iPhone, Wifi or 4Gi : OK

  • from laptop : Wifi or 4G : NOK

Connecting to page, I get to set my mail / password, then a page with my device appears

Then I click on it. NOTHING !!! I tried several times, same problem

The worst thing is that after this attempt, i can’t get through iPhone eiher ! Need to reboot the device

A there is no way to upload anything but photos or videos from iPhone, IT IS totally useless for documents  and can’t be used as a real personnal cloud

I should have read forum before ! This case happening A LOT. And it doesn’t come from connection (as it works from mobile device - Wifi / cable or 4G). Seems to be something on WD server that handle remote connecton which miss somthing with connection coming from Windows

I hope WD will get to a solution !

That is what happens to me if I use IE11 or Chrome browsers.

However it will work with firefox, as long as you have not updated java to the latest release, and go to the lego brick symbol at the start of the web address box and allow access for this site.

Thank you for your feedback. I’ll try tomorrow from office and tell you if it worked for me as well


It works with Firefox but **bleep** IT’S SLOW. Much slower than from mobile app

Yes I agree, far too slow to watch a media file live, I have to copy them first which can take hours for a film at reasonable quality.