Remote Access without MioNet


#1

I want to be able to access the My Book World Edition I just bought from any remote location. I have been experimenting with opening ports to it on my router, etc. and I think I had it working for a while but then it stopped. I have enabled remote access to my router but I can’t remember how I managed to access the NAS. I don’t want to pay for MioNet and I know this can be done, however I can’t figure out how to do it.


#2

What you need is FTP

If it’s the my book world (white light) then first you need to make sure the FTP service is enabled by accessing the network storage manager and going to advanced mode network then services… You can change the port if you want

-then open the port on your router for the ftp application with your IP of your drive

-You need to have a public IP, i guess that will be provided by you ISP

-you can use FTP client application to access it remotely

ISP should be able to help with this procedure as well i guess

FTP is faster that mionet, as it will give you direct access without having to go through any third party server


#3

Hi,

I’ve set up the ftp server on white ligh on my book, but I can’t access it from remote (public) IP - although I’ve forwared the port to the my book ip.

The error I get is:

Entering passive mode (192.168.1.2,19,224)

The my book sends the internal ip address back to my ftp client, and tries to use passive mode - since the ip is on my internal network, it fails to enter the passive mode and I can’t connect.

From my internal network, I can connect to the ftp server and transfer files.

Am I doing something wrong?

Thanks in advance.


#4

The tips here might help, or at least explain why FTP is failing:

http://www.ncftp.com/ncftpd/doc/misc/ftp_and_firewalls.html

If your firewall doesn’t support monitoring for FTP PASV connections and dynamically changing the IP and opening ports, then there might not be much you can do. You may need to turn on Stateful Packet Inspection (SPI) for this to work.


#5

For Filezilla, you have to choose active mode over passive mode under transfer setting, else the default mode for filezilla is passive mode and it does not switch over properly, not sure why also…

But using bulletproof ftp is ok without any setting.


#6

This is pretty easy and worked for me on my Seagate NAS and now my WD NAS.

Log into the WD NAS, go into the Network tab.

Create a local static ip address.  (EX) 192.168.1.xxx

Default gateway will prob be. 192.168.1.1- connection between the NAS and router.

Go into your router and setup portforwarding.

Type the port you are using in the NAS and the local network static IP addess that you setup.


1st.) Join up for a Dynamic IP routing website such as dyndns.com

This basically uses your dynamic IP address from your modem and tells the website when your outside IP address changes.

If the IP address changes, the website picks it up.  You will always use the username to track the NAS.

Simple terms.  This screen name= having a Static IP address.

2.) Put this account name into your Router -DDNS Section.   (Ex.) XXXX.dyndns.org

When the router sees that the modems IP Address changed.  This will update the website.   The IP address can change as much as it wants.  You will always keep the same screen name.  Pretty easy and cool.

  1. Now in your router since FTP uses some Other ports to send files sometimes (besides the One you can change in the admin screen).  Turn on your DMZ option to turn on all the ports.  (not the best to do long term for security).  but will work till you figure out what ports are being used.

  2. Use a FTP client such as Filezilla.

-Type your username into the address field.    (EX) xxxx.dyndns.org.

-User- Screen name you use to get into your NAS

-Password- Same to get into the NAS.

-Port: What your using in the NAS.

(This program should also take care of the Passive/Binary Mode automatically)

As for just streaming files to your computer from the NAS.

You can go to your Internet Explorer bar and type in

ftp://XXXXX.dyndns.org:YOURPORT#/

Make sure you have FTP turned on in the NAS.

Pretty easy to set up and get running.