Remote access stopped working recently


Came home from a two week trip and cannot access my cloud remotely.

I can access it from my computer connected to the local network. Also iOS app connected to the same network with wifi.

However I cannot access it externally, which worked before I left and also a couple days after when I connected to it.

In the settings it shows that remote acces failed. I tried port forwarding on my time capsule (using it as router) but with no success (followed a guide linked to in another post). Have added static ip.

Also, I get a blank page when I go to and try to sign in. Not sure if related or not.

Please help!

Access the Dashboard > Settings and turn Remote Access OFF. Wait a few minutes, then turn Remote Access ON. Then wait to see if the Connection Status indicates a connection.

I tried it a bunch of times, also again today.

I did note that this morning it changed status to active relay, I tried logging in to and it worked although I could not access my drive as it was shown offline.

Had to leave but now that I try again (and turned the service off and on) it fails again. I cannot login to either. Somehow it feels like they are related.

Any thoughts?

Still not working. Tried different ports and different configurations. Nothing works.

Still shows failed for remote access. I can’t figure out why. Need help to figure out next step!!

Have you checked with your broadband provider to see if they are blocking ports on their end? Some broadband providers will block ports. Could be your provider either started doing it for some reason.

Other suggestions, check your router for port forwarding and adjust if necessary. If remote access within teh Dashboard is set to automatic, change the remote access on the Dashboard to manual and set alternate ports (for example 8080 and 4443). Access your router’s administration page and setup port forwarding to these new ports. Then turn off remote access within the Dashboard, wait a few minutes and turn it back and check the remote connection status again.

Of course: if the device can’t establish a connection to the internet, you will not be able to access it from the internet.

Has your router upgraded its firmware? Does it have UPnP control enabled?
Is your MyCloud set to automatic connectioin mode?

I too have recently lost remote access. On dashboard, Connection Status : failed. I have not contacted my ISP on the subject of any changes. In addition, I have had no luck with the manual setting. Although, I may be in error when trying to configure my router’s ports. The HD is on a LAN with access to the Internet, and nothing to my knowledge has changed with my LAN. Within my LAN, I have full access to the HD.

Sorry, a bit unspecific. I can’t even get the login page to load, I just get a white page. The times when I have been able to login I can log into but it says that the device is offline. Obviously I can’t reach it until remote access is active again.

It has internet access (status and also successfully sends test emails), steady blue light.

It has the latest firmware as well, set to auto update.

Tested both automatic and with manual port forwarding. I have a time capsule as router and set up both static ip and manual port forwarding using random ports. (Haven’t needed any of above before though which is strange).

Haven’t contacted my ISP yet, sounds strange that they would close those ports but I’ll check with them. But if I set up custom ports, shouldn’t that still work?

having the exact same problem. Remote access stopped working without warning. Have full access on LAN, steady blue light and the remote access is turned on - and with connection ready.

Have tried fully restore and new setup - nothing changes. Still no remote access

Check the advice I gave in other thread. That should help.

No web-access via

Solved it! Thanks dan_sp!

The problem was with the DNS. Changed dns servers to googles ( and on both my router and my cloud. Few minutes later it worked.

Seems like there’s some problem with the dns I was using provided by my ISP (I’m in Sweden using Alltele as ISP).