Remote Access My Book Live

I just purchased My Book Live 2TB and now I cannot seem to setup remote access even though in settings under network it says that internet access is good.  I’ve tried rebooting the device once (forgot how I did that so haven’t tried that again) but there isn’t a point in having this storage device if I can’t get remote access.  

Have you already register an account in the remote access? And did you enabled it in the setting?

you have to update the firmware. some people can’t update the firmware through the dashboard unless they manually configure the network properties of the my book. go into the dashboard by typing //mybooklive/ into a web browser. then goto settings>>network and change it to a static ip. keep the same ip address. enter into the subnet mask. and enter the address of the router its using to connect to the internet. If your windows box is on the same router. type cmd.exe into the run menu and type ipconfig. the default gateway is the address of the router. then update the firmware twice.(prior to september you would lose your shares in this step)