Remote access fix


I was unable to access my MyCloud from outside the LAN until I disabled IPv6 on it. Now it works like a charm. After saving the file and restarting the problem was fixed.

I used the VI editor as gedit is not installed. Make a backup of the config file via cp  as VI is a nightmare for the uninitiated (like me). There might be another editor installed.

PS: I also did the Settings > General > Cloud > Configure > Rebuild DB before the IP6 disable. I don’t think it was related as the system still did not work for a while after that. I thought I would mention it, as I did see in another post that it fixed a similar issue for someone.

Disable Ipv6 (

Edit the file - /etc/sysctl.conf

$ sudo gedit /etc/sysctl.conf

And fill in the following lines at the end of that file

# IPv6 disabled
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

Welcome to the Community and thank you for your contribution. Although it requires SSH it’s nonetheless an interesting solution.