Remote Access: Connection Status ALWAYS shown "Connecting" (even I disable Remote Access)?


I just purchased the WD My Book Live, updated to lastest firmware.  I had setup the WD My Book Live using the UI interface, everything ok, except the Remote Access.

I tried many times to configure, however the Connection Status ALWAYS shown “Connecting” with “Trying to establish a remote access connection…”, the message still persistant even I disabled Remote Access!  Is this a bug?

I rebooted the WD MBL many times, however not successful, the Connection Status ALWAYS shown “Connecting”, look like a bug in the firmware.  :confounded:



Try connecting to a different port on the router

this is not happening to me

Hi Wizer,

Thanks for the respond.

I had tested the following senario, but still not working:

(1) Put the WD MBL in the DMZ segment of router (all ports will be pass thought to the WD MBL)

(2) Port forwarding at Router (80->80, 443->443, 21->21) to WD MBL

(3) Port forwarding at Router (8080->80, 8443->443, 821->21) to WD MBL

However, all the above senario, the WD MBL shown internet connection is “OK”, and I manage to access to WD MBL for FTP service and the WD MBL Web UI (port 80 & port 443) using another internet connection to my home connection.  But, the remote access connection status still shown as “Connecting”.

I even tried to disable the remote access, the remote connection status should be shown as “Disable”; but the status still shown as “Connecting”; which make me guest this is a bug in the latest firmware.

I had escalated the case to WD support (with screen capture), but so far no feedback from them yet.  :frowning:

Since remote connection access is build in feature for WD MBL, I don’t mind try it out, at the meant time, I will using FTP.  I will configure the Secure FTP, if the remote connection access take too long to resolve.



I discovered that the displayed status is dependent on what the communicationmanager program on the drive reports to itself.  I’ve found that program to be buggy (in my case it won’t send my external ip address to the WD servers so it won’t set up remote access correctly).  Maybe there’s more bugs where it won’t send the status correctly.

If you want to ssh into your box, there’s a command you can issue to force the status to “disabled” (or whatever status you feel like).  Of course the communicationmanager will just change it again, but if you set it to disabled it should stay that way.

I don’t have the command in front of me at the moment.  I can go look it up later if you’re interested.

What’s the ssh command?