Release 2.02.32 and can't connect to the Wifi

Hi guys,

I’m new here and I got a WD TV Life Streaming Box today and updated it to the newest Firmware version.

But I’m not able to get it connected with my Wifi.

A) After a reset and getting it started again I doesn’t show me any Wifi network to connect to
B) I checked the WPS Setting and it is set to automatic connect, but how can I prompt it to look for a WPS signal?

Is it a bug or does my box have a problem? How can I get it solved? I checked already the forum here and tried a hard reset from electricity, a reset via the menue a reset via the reset button …


Best regards from Cologne, Germany



Welcome to the WD community,

I haven’t seen this situation with the unit on this firmware.

As a recommendation, please perform a factory reset through the settings.

Please see page 198 of the user manual for assistance.

If you already did this, try the hard reset using the reset button on the back of the unit pressing that for 4 seconds.

Hi ERmorel,

Thanks for your replay. I tried the reset through the settings… Nothing. I tried the hard reset… Nothing…

Via LAN I get a connection of course, and I also have the Wi-Fi Direct stuff and the WPS automatic connection point in the menue, but it is not showing me any selection for “WiFi or LAN”, neither it is showing me the available WiFi AP’s nore a chance to start the WPS connection.’

To be honest, I’m absolutely lost. I checked other entries here and found some which had the same problem with a fromer firmware release and also tried their solutions… Nothing worked so far…


Best regards


By the way ERmorel…

Check this:

I’m not the only one with this problem…



Hi sam_Cologne, we have passed this along to support.