Refresh Samba Network Share Content IMPOSSIBRU!

I’ve seen this referred to often enough in my searches. It’s really starting to ■■■■ me off though.

I DESPISE the Media Library **bleep**. Slow and unseemly for my setup where content and locations are changed often enough for it to be just annoying as **bleep** to have to refresh/update the media library so often.

Regardless of this. The WD TV Live Hub just flat out REFUSES to update/refresh the content of a Windows 7 Ultimate X64 Share…

So far as to be still showing content that was deleted or burnt to blu-ray for backup days after the last firmware update…

How **bleep** hard would it be to add a simple ‘refresh’ task to the option menu? Seriously. With all the personalisation options for buttons A through to D and 1 through to 9, surely there is enough scope for just ONE of these to force a REFRESH of the content of the current location.

For those who suggest to turn the media library on and off, been there. Done that. Does SFA.

For those who say to change the workgroup to something else, then back again. Does SFA.

For those who say to clear the network login and share info. I’ve done that over and over again. Does SFA.

For those who say to Restart the Device, either by the system setup option or by holding the power button on the remote OR device until it completely shuts down… Been there… Done that… DOES SFA…

Noticing a trend here?

I’ve tried pretty much everything I’ve been able to google or think of to no avail.

For a media player that I’ve had so much praise for. It seems to really be struggling with the last few firmware updates. It’s losing functionality and usefulness just so it can be equipped with pissy little mindless games??

Come on now. It’s a media player. Not a Game centre.

I buy a media player to play media. If I want to play games… I have a Console for that. If I want to go online and check facebook and twitter… I have a computer for that…

Just fix the **bleep** thing so it actually works without causing me ENDLESS frustration…

If you can’t at least get that right… Release a revised chassis version with at least one e-Sata port on the back of it so I can give it more ‘local’ storage… The only **bleep** storage it manages to refresh competently, without lumbering me with some archaic USB device that takes a million years to copy to-from via my COMPLETELY Gigabit equipped wired network.

See… I’ve sent emails. Not even the courtesy of a **bleep** reply.

I’m pissed off enough now that I’ve wasted my time signing up, opening an email address up for whatever BS messages I’m likely to incur from the mere act of signing up.

I don’t need some gimmicky media library nagging at me to be refreshed or updated if I move a shared drive from one PC to another. Waiting for just ONE 1TB drive full of media to refresh/update is bad enough. Let alone half a dozen of the things…

If all these stupid little apps and ‘services’ can be added… surely ‘Refresh’ can’t be that big of a **bleep** ask.

/RANT (for now)

In the event of a random spate of logic.  Once in a blue moon it MAY all of a sudden update the content of a share.  It doesn’t seem to follow any rhythm or logical pattern.   I have disconnected the thing completely at one point.   Let it sat for a half hour while I unwound, then hooked it all up again, cleared the network login/share information etc etc…  Only to find that it still doesn’t refresh the content of a network share.

If you’re not using media library, there’s nothing to refresh.

All you have to do is go to the Home menu, then back into Videos (or whichver) and the content is updated.

If that’s not the case for you, I have no clue what the issue could be… 

I use the Media Library all the time.  All I have to do is hit OPTIONS / RESCAN … and all changes are immediately updated.

Sorry you  are having such a hard time with this but I’ll confirm what Tony states above. I also use the media library for everything without issue on the latest FW.

As soon as I add a TV show or Movie I just go the folder above that (EX: I add a TV series under a directory called “TV”, so I highlight the “TV” directory) and then hit “options” and then “Rescan” and it immediatly appears.  Seems to work flawlessly and I am doing that on network shares.

Good luck.


My big difference is that I don’t use Media Library.

Because it does become so time consuming and cumbersome.

I understand that it ‘Should’ refresh the content displayed in the GUI, either by the File manager or through the Media selections of Video, Music or Photo…   It just doesn’t.   

Hasn’t done for a couple of firmware updates now.  However, I didn’t think at the time to write down the exact firmware that it started having issues from.   Even regarding XP shares, it’s been the same.   I just half expected a logical thing like a manual refresh to be added to one of the firmware updates.   It makes sense.   Unlike so much of the junk that has found its way onto the device.

However, today has been the final straw.   It seems the HDD Controller has shat itself.  Losing access to the 1tb internal drive.  Just to check it wasn’t a full unit crash, I have another 1tb drive connected via USB and that works just fine.  

Going to check my warranty dates, if it’s expired, I’ll likely try and open it somehow and get at the drive manually… Try it in a dock to confirm if it’s a controller or drive issue…    Assuming they’re using a similar filesystem??

I must add… I find it highly amusing that words, unhyphenated, such as cr-ap and da-mn are considered swearing.  let alone ‘bleep’ worthy.

After a quick serial number check.   Warranty is over by all of 1 and a half months.  In the process of opening it now to get at the hard drive.  I must say, if it turns out the drive itself is fine, I won’t be purchasing another WD media player.  What with the moronic IR issues of the first one that required the stupid bit of plastic to be drilled or removed just so you could operate it from more than a couple of inches away, and the Hub with which I had the first one die within days of getting it, only to be replaced with one that has only lasted just beyond the warranty period.  

I don’t like spending my money more than once.  Especially not on products that rapidly show to be lacking in quality of build or performance.  Moreso if either is sacrificed to add flashy, gimmicky features…