Red light no access

I have a solid red light at the front. I have tried the 4 sec and 40 sec reboot and still unable to access any data. like most people, I have so much data on this hard drive I and struggling to comprehend the loss of data. Changed network ports, power cables and still nothing. Unplugged from hub and plugged directly into PC with network cable and get a green link light but still no data. Cant get to the dashboard. Cant afford data restore costs. 12 months out of warranty. Absolutely devastated. Any pointers?

Remove the My Cloud hard drive from it’s enclosure. Use a USB to SATA adapter/enclosure/docking station to connect the drive to your computer. Then use Linux boot disk/flash drive or install Linux drivers in Windows to access the My Cloud hard drive contents. From there you can copy the contents to another drive and or attempt to “unbrick” the My Cloud hard drive using one of the various unbrick methods (use forum search feature, magnifying glass icon upper right to find unbricking discussions).