Red light and no connection

Last week when I went on holiday it worked fine, but today my iPad and iPhone get a pop-up saying it’s offline and my MacBook can’t find it at all.
I’ve tried reboot and various ports in the router, each time the blue light comes on for about a minute and then I goes out again. I can hear it’s doing something, but I don’t know what.

What is going on??

UPDATE!!

I disconnected the drive for a day or two and now reconnected it just shines a bright red and I can hear it going in circles. How can it just break like that, no warning what so ever?? No one what so ever had touched it or was anywhere near it.

Did you go from iOS12 to 13? Than try this on your iPhone and iPad. It worked for me.

Bypass HTTPS Validation in the My Cloud Mobile App by following the steps listed below to disable and Bypass HTTPS Validation in the My cloud Mobile App:

• Open the My Cloud mobile app
• Tap the 3-line menu icon in the upper left corner of the screen
• Tap “Settings”
• Tap on the words “App Version” 4 times very quickly to access the debug screen
• Tap on “Bypass HTTPS Verification” (Slider ON) to enable
• Tap “Done” in the upper left-hand corner of the screen
• Close and open the mobile app

Perry

I’ve tried that on the iPad with no success.
My phone is 12.2 and either way it wouldn’t explain why the computer can’t even find the drive or why the light on the drive goes out all the time.