Red LED, web interface accessible, drive usually mounts via share - MyBook Live (3TB), Windows 7


After applying  firmware update 02.10.09 (apnc-021009-124-20111113.deb) I get a constant red LED on the drive.

I upgraded another MBL/3TB unit – the mirror drive to the troubled druive-- on the same LAN without issue, as well as two MyBook/2TB units (and their latest firmware update).

The web interface is functional and the drive seems to be mountable via all of its Windows 7 shares.  I have tried to do a manual firmware update to 02.10.09 to clear the red LED issue, but to no avail.

Options I’ve considered:

  • downgrade to 02.03.01 (apnc-020301-024-20111019.deb) - tried, but get ‘network connectivity’ error message
  • forced re-install of firmware rev 02.10.09 (apnc-021009-124-20111113.deb) - now give ‘network connectivity’ error
  • Ask for a ‘force to base firmware’ program to force everything to the original factory state, firmware-wise
  • Solicit other options from this community

The 3TB drive is 85% full and its mirror is not fully up-to-date, so I want to try to protect my data as much as possible.

Both MBL/3TB units are under 3 months old (from the store, Microcenter).

Recommendations, please?

Lisa B., Bolingbrook, Illinois

Addendum:  Message code was 30000 (subcode 0) for the ‘network connectivity’ complaint above.

This is a known issue and there’s no real fix right now :confused:

That’s why I decided NOT to update my MBL.

1 Like

I elected to do a manual firmware update (same version in my orifinal post, 02.10.09) before I headed to work (Tuesday, 12/20/2011, 7 am CST).  When I returned home (7pm CST). The drive light was a slowly blinking green and all functions on the drive are working OK.  The short diagnostic still hangs at 90% complete, but the firmware re-install seems to have resolved the issue.  Whew!

Feeling like I barely avoided bricking my MBL,

Lisa, Chicagoland