Recycle bin corrupted on WD MyBook 8TB

Every time when I start my computer, I get the message:

The Recycle Bin on H:\ is corrupted. Do you want to empty the Recycle Bin for this drive?

H:\ is my WD MyBook 8TB. Its recycle bin is empty.

After doing a little research on the internet, I’ve learned that it often helps to run the following command at the Command Prompt window:

“rd /s /q H:$Recycle.bin”

I have done this maybe 30 times, but each time when I restart my computer, I get the message again that my recycle bin is corrupted. I’m getting quite desperate over this. Can anybody help?


Hello There,

Try to see if the information on the following link is helpful for you:

If you check on the bottom part there are 3 methods to try, check if trying any one of those helps you out.



Thanks for the suggestion. I tried to uninstall the WD Security app because the other options did not work, but now I completely lost access to My Book.

H:\ is not accessible.
Access is denied.

When I try to modify the permissions in Properties/Security, I get the following message:

An error occurred while applying security information to:
Failed to enumerate objects in the container. Access is denied.


Unable to save permission changes on My Book (H:).
Access is denied.

Basically now I’m completely lost. Please help!

Many thanks,

Geen reactie? :confused:

I could not find a Recycle Bin on my [H]:\ drive either.
I deleted some files on the [H]:\ drive and when I searched for them, they were in my C:\ drive Recycle Bin.

I get the same message each time I start my computer as well. I tried the [H] directory folder settings to show hidden files but the $Recycle Bin did not show up.

So I have a secondary question. Why isn’t there a separate Recycle Bin on the [H]:\ Drive? When I click on the C:\ drive Recycle Bin properties I note that two recycle bins are shown for the C: and the H: respectively. Does this mean that the Recycle Bin is being used by both drives?