Recovery errors


#1

I have been experimenting with WD SmartWare, and recently used it to back-up a drive and recover it onto a blank disk after a failure.  I found a number of errors of the form “Failed to find metadata for file …” and “The file’s path is too long” which prevented files from being recovered, in spite of the fact that I didn’t see any warnings about this during the backup.  Unless this is fixed, I would not trust this software for any critical backups. If the software is for use with Windows, it should accept any path name accepted by Windows.  I don’t know what the lost metadata means. Fortunately, I have redundant backups of everything important, which is a  good idea in any case, since a backup drive could itself fail during recovery.  (I’ve seen this happen.)


#2

I’ve found another recovery error:  One one backed-up disk, a complete set of files is shown in the “Retrieve Some Files” listing, but any attempt to retrieve one fails with the error “The system cannot find the path specified.”  Thus, although the Passport Essential hardware is still working, the Smartware software has apparently lost this disk’s backup.


#3

I have the same problem with my Elements drive… brand new.  Copying files to it and it belches that “filename or path is too long” or it says “it cannot find a file; that it must have been moved”.  How can it move when in the midst of copying it?

When it belches in the middle of a backup or a transfer of files, I suspect it will lose all of the data because it won’t finish the backup or transfer.  I hesitate to keep a drive that has shown a propensity for failure already!

I sent email to Support because I see the original poster here hasn’t received any answers or input.  Surely there is someone at WDC monitoring these posts and replying to them… but I guess not.

We need some help with why it is doing this and what do we do to fix it?

I’m thinking I should take the drive back for a refund and switch off of WD for drives from now on.  Right now I have 4 WD external drives and they all work fine except the newest one (this one, this problem).


#4

I discovered something new about the apparently lost files, whose names were too long, or which simply were lost from the backup records.  By “exploring” the drive, I found all the files stored under one of the folders on the drive, and was able to copy them back onto my replacement disk, although the software had lost them somehow.  Since then, I have uninstalled all of WD’s backup software, and just copy files to folders on the drive by hand when I want to make a backup copy.


#5

For 2feathers  - I think what you are seeing is probably purely a software issue, and has nothing to do with the physical reliability of the hard drive.  The drives work fine without the Smartware: you can just uninstall it and treat the external drive as any other external drive.  Just open the drive in Windows Explorer.  If autoplay tries to reinstall Smartware in the future, click “No”.  Unfortunately, part of the disk is partitioned as a “virtual CD” containing files to implement the Smartware, which I consider to be wasted space.  I do not know whether it is safe to repartition the drive and remove this, but suspect that it is, since the drive works on my Linux systems which do not recognize the virtual CD partition.  I would be interested to hear if anyone else has removed this junk without problems.


#6

Updater:  I sent an email to WD customer service and they have responded.

I agreed maybe Windows 7 Pro was concealing some path and filename restrictions.  I followed their suggestions and tried to relocate files out of the depths of my file paths and they copy… one at a time.  But if I try to send them to the Elements drive in mass, they belch.  Running them back and forth in their original paths with their extra long filenames between my two MyBook Essentials drives and my C:/ drives is no problem so I don’t buy that it’s the Smartware doing it, or that it’s Windows 7.

I copied a few of the subject files (150 of them) from MyBook 1 drive to MyBook 2 drive with no problems.  I tried to copy them to the 2TB Elements drive and it belched and left 150 key files not copied.

So then I ran the DLGDIAG (Windows Data Lifeguard Diagnostics) on the Elements drive as was suggested but it would not run because it didn’t pass the “cable” test…“Cable Test::Write sector error!”   I ran the diagnostic on my two MyBook drives and the test ran smoothly on each so I knew their cables were good.  I swapped the Elements drive’s cable with one from one of my MyBook drives.  I got the same result with the Elements drive:  “Cable Test::Write sector error!”  I ran the DLGDIAG on my MyBook drive with the cable that shipped to me with the Elements drive and the cable passed so I made the assumption that the cable was really NOT the problem.  To be sure, I ran DLGDIAG on my MyBook a couple more times and it passed each time.  I wiggled the cable a little at both ends to see if there might be a loose connection, but it still passed when connected to my MyBook drive.

I ran the test again on the Elements drive with one of MyBook cables and it again failed right off.  I swapped the cables back to their respective original drives and ran the test again on the Elements drive.  It failed to pass the cable test again.  I wasn’t convinced just yet so I repeated the test one more time, and eureka!  It passed!  So then I ran the DLGDIAG on the Elements drive 5 consecutive times with 1-2 minutes rest between tests and it failed the cable test 3 out of the 5 runs.

The Elements drive I have is showing intermittent problems and can’t be trusted so I’ve requested WD replace it.  I’ve only had the drive less than a week and I’ve not loaded it with data yet so I’m glad it showed up now instead of later.

NEVER trust your data to just one drive.  I learned the hard way long ago and a backup for a backup is not a bad idea if you can manage them.  I love the system imaging of the WindowsImageBackup of Windows 7 Pro so I never have to rebuild a C:/ drive and reinstall all of my applications ever again.  Moving to a new computer with Win 7 Pro is just click-click-and click.

But none of that is any good if my storage drives are insufficient or defective. 

I have kept my faith in Western Digital over the years and this incident is a bit worrisome, but my first in more than 20 years of working with them.  I was pleased with their response.