Recent problems with WD Photos Classic


I have a MyBook World Edition and I’ve been using the WD Photos Classic iPhone/iPad app. Its been working for a long time. However, in the past week or so, I am unble to see many of my photos in full. The directories all seem to be there and I can see them all in the app. However, when I click on a thumbnail I see the default image; the one that show the dog and 2 people, a child, and a balloon. I’m not sure what that image is called.

I don’t see my image in its full size. This used to work. Did anything change on WD’s end? I deleted the app and reinstalled but to no avail. I have the same result on my iPhone and iPad.

You guys didn’t drop support for the MyBook World did you?

Any suggestions would be appreciated.

Thanks in advance,


Hi, try pressing the reset button on the back of the my book for 4 seconds. 

Is that the same as stopping mionet and then rebooting?



I have exactly the same problem. The thumbnails download fine but the full picture version of the thumbnail will not download. I have tried a reset without success

Does it work in the “Test Drive Demo” or whatever it’s called?

Yes, live demo drive works fine, but is that a different drive type than mine? I have the world edition, probably 3 years old.

Any ideas? I would hate to have to replace the unit since it works great as a NAS device for our home network with backups, etc.


Yeah, but that shows that the App itself is probably working OK.

It may be an issue with your drive, in which case you might try posting in the forum for your hardware.

In my case I have exactly the same problem in DemoDrive.

Any suggestions welcome.

Same problem for me…

Doesn’t work anymore with mybookworld duo.

Works great with a mybooklive duo.

Demodrive not ok for me too.

Jaypidor wrote:

Same problem for me…


Doesn’t work anymore with mybookworld duo.

Works great with a mybooklive duo.

The same app cannot be used on MyBook World and My Book Live.

You must use the WD Photos CLASSIC app for the My Book World.

I use wd photo classic.

For both.

It’s not possible to use a mybookworld with wd photos (neo)

But it’s ok with à mybooklive and wd photos classic.

And for a mybookworld with classic.

It was ok in september 2012

I tried without the mybooklive and only mybookworld in classic.

Still thé same… (even after reinstalling app)

Same problem here. All used to work, but now no more…

Thumbnails all show but when you select them, no picture arrives - just stays with default image of family with dog and balloon…

I think a little circle going round to indicate the image was downloading to the phone was there before when selecting an image to view, but no longer.

Tried resetting Mybook World edition. Also deleted then reinstalled app on iphone (Classic app of course).

Same result whether accessing at home or via wifi/3G elsewhere.

Have latest firmware for NAS and latest version of app.

Incidentally, swiping sideways once a folder is selected increments the Image number in the folder (not) being viewed - i.e 1 of 12, 2 of 12 etc. Just doesn’t display any image other than the default one…

Demo drive does exactly the same thing, which suggests it is not the NAS and likely the app or something at WD’s end - especially as we all seem to be getting the same issue.


I have the same problem from a WDShareSpace

What is strange is that there are a few original photos that are viewable!
5/1000 LOL

For the rest all the thumbnails are actually created.

Hi. I experience the same issue. I raised a call with WD support ref. no. ref:_00DU0Jpn7._500U061TBa on 9th dec 2012.
I got a reply on 2nd Jan providing no help to which I responded that the response was inadequate. I have no idea if Wd support are still on the case or not. I hope some one gets a resolution to this. I too get the occasional picture after flushing the cache but then after browsing 6 photos it appears not to try and just returns the default place holder image and then fails on that.

There seem to be quite a number of people with this same problem; I’m experiencing the same issue. Thumbnails are only visible with the occasional full size picture when you first start the app. I’m viewing on an iPad and an iTouch and accessing a WD ShareSpace NAS using WD Photos classic. The Demo drive has the same issue. The problem is the same whether on the home network or accessing remotely. I’ve tried all the suggested remedies including new device name on Mionet and re-index, re-install the app etc. And yes the indexing process was completed (took almost a week). I raised an email request for help with WD a week ago but not yet heard anything at all. It would be good to know if WD is working on a solution and how long this might take.

I have resisted giving feedback on the Apple store so far but next time the app requests me to provide feedback it will be a one star (as you cannot give 0) and advising others not to download and waste their time until this issue is resolved.

I noticed EXACTLY THE SAME problem with my iPhone & iPad running WD Photos Classic and the World Book Edition Drive. This problem started since more than one month ago. Something was changed in latest release of WD Photos Classic that it only loads THUMBNAILS and never the full picture again.
It used to be a GREA APP, and now it simply does not work anymore. Is somebody from WD Tech Support going to provide us, their loyal customers for LONG a straight answer ???

The development team has been notified with this issue. Note that if you need direct support from WD, you can call or email tech support.

It would be great if we get a solution to this but I raised a support ticket for this at the end of last year and received a very disappointing reply followed by silence. But fingers crossed.

Last update of wd classic fixes the bug! Yahoooo!