Recent drop in access, transfer and processing speed

Hello everyone,

I have a WD My Book Live 2 Tb for about 2 years now, it has always worked quite well. File transfer and access speed were correct, they used my internet capacity to the max (~7 Mbps = 750 kb/s)

During this last week, both file transfer and file access speed have dropped significantly, resulting in slow transfers and even lag when playing media via DLNA. Everything is slow, even accessing via SSH you notice it takes longer time to respond to commands.

It had happened a couple times before and it was solved by rebooting both the disk and the router. However in this case it doesn’t help.

I know it is very hard to debug these issues, I just wanted to ask if something like this has ever happened to any other user? could it be that the drive is becoming old, or that it is too full? (~90%)

Thank you

There are a couple of ways that you can improve your network transfer rate.

See the suggestions on the following link:

Thank you for your suggestions. Actually I was more worried about the drop of processing speed, which could mean the disk was damaged or malfunctioning. 

However everything was solved after a couple more reboots, I really hope it is not a recurrent problem.