Re: New Release - My Book Studio Firmware update for Windows & Mac (5/20/10)


#1

Unfortunately this has not worked for me on a Mac.

When I run the firmware updater, it immediately unmounts my drive and then tells me it cannot find it!


#2

More Information …

My current firmware is 1.004, trying to upgrade to 1.012. connected via USB, no other drives attached, disk unlocked.

Running OSX 10.6.3

When the firmware updater runs, it unmounts my drive and then says it is waiting for a drive to update the firmware on.

While the updater is running, the drive cannot be remounted with disk utility, when the updater is terminated it is then possible to remount the disk.

Is anyone else seeing this behaviour?

Has anyone succesfully applied this firmware update?

I am trying to do this update in order to remove the virtual disk.

I also have another identical drive with firmware 1.009 where it was possible to remove the virtual disk.


#3

Make sure you are connected to the USB port and not the Firewire port on the unit. I fought this for a few minutes then realized that I was using Firewire. Switch to USB and it works great!


#4

As previously stated, I have been connecting via USB


#5

I’ve had the same problem.  I purchased a 1.5T My Book Essential last weekend and was confused with it’s odd Smartware software that forced itself onto my system.  Ignoring that, it was working fine on my MacBook Pro and Time Machine was using it as a backup drive.  The new firmware update was installed and now the drive has completely disappeared!

I’ve tried every possible sequence of unplugging, reconnecting etc, with no luck.  It’s connected via USB and won’t appear anywhere on my system.

I hope there’s a fix released for this, and quickly!


#6

also unsuccessful using the firmware updater; error message says “StrlD-DiskInUseUpdateFailed”

then it unmounts and I have to go thru the disconnect power/USB/reconnect power/USB sequence to mount it again.

Very dissatisfied with the performance of this external HD thus far; it disappears when it sleeps, I unlock it and sometimes it doesn’t mount.

Hope this firmware upgrade (when ultimately able to apply it) is successful, as I’d like to recommend this product to the rest of the university community – which I can’t honestly do at present.


#7

I’ve posted more details on the other thread, but it’s looking like this firmware is bricking drives.

DO NOT UPGRADE TO THIS FIRMWARE !!!


#8

I updated 4 My Book Studio (2TB each) and 1 My Passport Studio (500GB) using the last firmware and SmartWare updates, with success, in both PC and Mac. The only issue I had is that 2 of the My Book Studio in PC was keeping saying drive was busy (probably some software in my PC trying to read/write on them), but when I plugged them to my Mac updated successfully. The other 2 drives were updated on in PC (with success) and the other one directly in Mac.

It’s important to mention that this is not supposed to delete the Virtual CD, but to hide it. I successfully got all of them hidden using WD SmartWare (“not that smart”).

It was a late solution, but better than never.


#9

Hello Everyone,

This My Book Studio Firmware updater for Mac is for My Passport Studio and My Book studio.

*****It is silver looking case with both USB and Firewire connections *****

Please carefully follow the instruction on the web page as it will lead you.

Use the USB connection only during the firmware updating.

Disable or remove security or password protection before doing the firmware update. 

Be sure to wait for the firmware updater to finish.

Restart the computer and power cycle the WD My Passport  Studio or My Book Studio drive after firmware update is finish.

If you have WD external drive with black case use this link instead 

http://www.wdc.com/wdproducts/wdsmartwareupdate/step1.asp?id=wdfMB_Elite&os=mac


#10

I’m also having problems updating the drive. Everytime I try to update the firmware, the updater says that the firmware file can’t be found. FYI, my drive’s firmware is v1.009.


#11

Same BS problem. (i.e. firmware can’t be found).  Trying to update a Passport Studio for Mac.  The windows version of the update doesn’t work either.  It just sits and grinds and grinds and does nothing.  Left it running an hour and it did nothing.  Guess I am lucky it did not brick the drive.  WDC has no idea how to program or test anything so it works.

Pretty much ready to toss this thing in the garbage.  Next time I want a firewire 800 drive, I’m getting a Seagate GoFlex or building my own with an OWC enclosure.


#12

I have the very same problem with the My Passport Essential SE 1Tb.

I did as suggested from the readme the firmware upgrade and now the disk is not readable/accessible/recognized anymore. Neither in Win or Mac (under Win the .zip containing the firmware upgrade is corrupted and cannot be extracted).

Now I’m in the state that I have a dummy disk, bricked, which is neither recognized by Disk Utility and the only thing I can see of the disk using System Info is this:

 Product ID: 0x1617

  Vendor ID: 0x13fd  (Initio Corporation)

  Version: 1.00

  Speed: Up to 480 Mb/sec

  Location ID: 0x26400000

  Current Available (mA): 500

  Current Required (mA): Unknown (Device has not been configured)

Please help us!

btw, I’m using it via USB and using a MacbookPro unibody 2009


#13

I will have someone help you.


#14

I have some updates to share.

I was on the phone today with one of your support guys and we did some little experiments.

Sometimes it seems that the latest firmware update procedure on mac doesn’t go as it should, and fails. The firmware update app is unable to hook-up the “usb alien device” detected from the system and restart from there to reflash the nvram on the Initio chipset.

Apparently, this is not true on Windows Side. So what you have to do:

  • is to fire-up a Windows XP

(please note: I used Parallels to virtualize my Windows guest OS, even if the entire upgrade process is a very so deep level IO activity over USB, so just as a disclaimer, mine worked, yours, I don’t know. P.s. Didn’t test it on W7)

  • downloading the Firmware update in his Windows flavor from the WD Download Page

  • restart the firmware update procedure

  • it will take 1 to 3 minutes for the whole procedure and will refresh your disk chipset.

In my case, it saved also the partition schema I was having before. So it worked.

As I was on the phone with this very nice and prepared guy, he told me that sometime this may happens, especially on MacbookPro’s… he doesn’t know why, but the fastest test to do is to try to reflash the firmware using a Windows Hardware (again, I tried ONLY Parallels, don’t know if it works with Fusion or VBox), if you have a REAL Win HW, well, worth a try there too.

The support representative also told me that as the device was new, he may have it repaired (read: replaced) in a short time (this was my 1st day with it).

So I hope this may help some of you. Despite the expensive international call I had to place, I was pleased from the level of support I received.

p.s. if you want the fastest IO throughput you better install the Turbo USB drivers (which are under the folder Extra of your original WS Virtual Disk) for USB. It was really improving the transfers.

Thank you.

@gpy


#15

There is no fix available for this problem.  Many people are having the same problem and WD acknowledges it.  The only thing that they will offer to do is to replace the drive if it is under warranty.  The problem is you have files on the one that won’t mount and that your Mac can’t see.

Here is the workaround that worked for me.  I hope it helps you.

  1.  Go to a Windows PC.  (I know, I hate them too but you want your drive to work on your Mac, right?)

  2.  Go to WD’s website and click on support.  Navigate to the page where you can choose your particular drive and then download the WINDOWS firmware update for your drive.

  3.  Hook up your drive (power and USB) to the PC and install the firmware update.  Your PC won’t be able to ‘read’ your drive but that’s OK, don’t worry about it.

  4.  After the firmware update is installed the hardware wizard in Windows will find the WD drive (still won’t read it if it is formatted for OSX).

  5.  Now, unhook the drive from your windows machine and plug it into your Mac.  Your once unusable drive should function as normal with all of your files still intact.

  6.  Don’t try to update the Mac firmware.  Leave well enough alone.  :-) 

Hope it works for you.  God bless.


#16

Same BS problem. (i.e. firmware can’t be found).  Trying to update a Passport Studio for Mac.  The windows version of the update doesn’t work either.  It just sits and grinds and grinds and does nothing.

I’m in the exact same position. Passport Studio 640GB @ 1.009. Trying to update on my Macbook Pro gives me an error message: “Update failed. Please try again (Firmware File not found.)”

I’ve tried updating on *three* separate Windows machines (one running XP, one on Windows 7, and one running Vista), and all three are unable to complete the firmware update. Like the quoted poster, the update runs for hours without ever finishing.

What gives? I can still read/write to my drive, but I can’t really trust any data to it in this condition now can I? When will we receive the assistance that was promised?


#17

I had this problem as well.  Luckily the windows procedure got my drive back, because  I was getting ready to smash this thing into the wall.

HDD firmware updates should be some of the most heavily tested consumer software.  How could something like this get through?