Random movies stuck at startup - reset helps


After upgrading to latest firmware 1.06.43  I stated to expierience following issiue. Randomly some files (mkv / avi) will freeze at startup (spinning wheel forever). If i reset WD (power cable out) they will work.

I have tried to rollback firmware and updated again - didn’t help.

Any one experienced that? Any fix?

If you goes back to the previews firmware, do you get the same results?

ragdexx wrote:

If you goes back to the previews firmware, do you get the same results?

yes. I always updated to latest firmware and had no issue. Than in january when ‘infamous’ firmware appeared I updated and started having this issue. After the firmware was removed from page I roll back to 1.06.15 (i believe) but problem didn’t go away. I expeded that wen new firmware will arrivie it will be fixed. So when 1.06.43 arrived I upgraded however issue still exist.

Possible I should rollback firmware once again / or to different version and than update again. No idea.

Did you hard reset the device before and after the update?

No, i didn’t. Should I?

So what would you suggest to do now? 

is hard reset just unplugging from power?

You can reset by either going into the system setup and selecting ‘Reset to factory defaults’, or you can press and hold the reset button on the WD device for a couple of seconds.

have done to following:

  1. reseted the device

  2. rollback to 1.06.15_V

3. reseted the device

  1. updated to 1.06.43

5. reseted the device

and… wow seems it helped!

thanks so much

well, the problem is not fix aparently. I power off the device for night and next day I turn it on and it stucked while trying to start movie that was perfectly working night before. This is exactly the problem I used to have.

I unplugged the device from power and movie starter properly after that.


There is some embedded code in certain files that stops loading. It stops not only the specific file that you tried to load, but prevents any similar files (basically any video or audio files) working until you reset the box. I think the code relates to anti-copying.

As a fix, I opened such a file in a video editor, checked that it ran, and the re - “produced” it as an mpeg2. It ran and never again interfered with any other video or music file.

In my case, I had purchased a set of 24 photography lessons from “TheGreatCourses”, which I wished to play through to my bigger TV over ethernet. I first tried saving to a USB stick plugged directly into WD LiveTV but it didn’t resolve. Now that I have reproduced all 24 lessons, I have no more problems.

I now believe that my previous intermittent problems with a Diamond MediaHD were caused by similar files of unknown code inclusions (but my WD LiveTV is 'way better)!

Jimi77 I have exactly the same behaviour.

I upgrade to .43 and after some days suddenly different type’s of movies didn’t start and are stuck at the start moment, you see the turning wheel. The day before, the file, worked well.

I did a factory reset and then all files worked well and again after some days same happends, films already played didn’t start and a factory reset has to be done to solve.

I have the box 2-3 years and are satisfied with it.

Some small problems happend to me but are solved during the years.

The latest firmware’s are working well for what i do with the box.

If this will be the final version of the WD TV live I’am very sad.

This type of problem where i have to do a system reset once a week, is one of the most worse failure’s i had until now.

Roll back will always gave me the update screen.

BTW in my case in concerns only movies shared / accessed through network. The problem is not present for movies on USB

In my case it’s also movies via Network from NAS

I did not check from other sources

yesterday again, box hangs on start of movie

Ichecked to switch of box instead of reset to factory settings and that works also.

Well i got a similar problems with a older WD TV Live Media Player (latest fw) brand new WD TV Live Streaming Media Player (latest fw) both presents the same problem and i have to power off problem remains… Fix please.

I am having a similar prob. Screen is locked up on Netflix screen where it is loading movie