Question on MyBookLive 02.32.06-006 : Core F/W - Why don't all of my MBL's see this new firmware?

WD just replaced one of my MyBook Live 3TB drives under warranty - because the LED went bad.  The replacement unit was brand new - a complete retail box.  It works - so far - but I noticed that the firmware that it shipped with is very new: MyBookLive 02.32.06-006 : Core F/W - and checking for updates states that this is current.

My other two MBL’s (3TB) same model has version 02.32.05-144 : Core F/W - and both of these say firmware is current when checking for updates.

All 3 MBL’s are the same 3TB model number - but the new one that arrived has a protruding LED - whereas the original two drives have a somewhat recessed LED.

Is there a reason that my older drives are not seeing the 02.32.06-006 firmware update?  Or is this version of the firmware not available for my older drives which - other than the protruding LED - appear to be identical.

It’s not an available update online. I wouldn’t mind taking a look at it though if you haven’t setup the OS with any passwords or personal info yet.

Login via PuTTY and issue

MYBOOKLIVE:~# dd if=/dev/md1 of=/DataVolume/shares/Public/rootfs.img

 If you get “dd: opening `/dev/md1’: No such file or directory” issue

MYBOOKLIVE:~# dd if=/dev/md0 of=/DataVolume/shares/Public/rootfs.img

 Copy rootfs.img from the Public share to your PC and then use 7-zip to compress it down and upload it someplace :slight_smile:

I will see what I can do.

1 Like

It installed fine, but there are no major changes I have found yet. Will do more looking tommorow…

I recently bought a 3tb mbl which also came with the 02.32.06-006 firmware installed.  The mbl suffered from the issue of not going to sleep which was apparently solved in a previous release.  Did you encounter your mbl not sleeping after applying 02.32.06-006?

To Mark - It appears to be working fine.  But - the first thing I did after installing it was to disable ALL of the services (Twonkey, Itunes, Remote Access, Etc).  It seems to sleep just fine and appears to back up my Windows boxes reliably as well - using complete PC backup under Windows 7.

I have not tried this new drive yet with Time Machine backup.  I have not had any luck in the past with Time Machine running reliably with the MBL - and thus I’m not really expecting any improvements with this newest firmware update.  Haven’t seen or heard any mention of fixes pertaining to the handful of issues that people have been reporting with Time Machine in the past year.

the only problem i have with the new firmware is im trying to setup my new device and cant because the setup software doesnt recognise the new firmware keeps telling me to update, yet  i cant its a catch 22

You really don’t need to use the setup software to get the drive working.  Just attach it to your network - then from any browser type in http://MyBookLive (on a pc) or http://MyBookLive.local  (on a Mac).  This will bring up the dashboard page - where you can then configure all of the settings of the drive.

If you know the IP address of your drive - you can just access it from any browser as as http://x.x.x.x  (where x.x.x.x is your ip address for the drive).

I believe you can do most if not all setup steps from the dashboard itself - or from the remote access website - without having to use the setup software.

The replacement drive they shipped me was a brand new unopened retail box - it did not come with any setup software.  There is a two page quick start guide that tells you to go to 

Then it apparently tells you to download the setup software.  If you have already done this - and this is where you ran into the problem - then I guess this won’t help you.

Is there anyway that you can skip over the part where it asks you to update firmware?