Question concerning data transfer speed

I have a 4TB MyCloud device, the main purpose is to use it as media server at home. LED TV’s in the house have all WD TV LIve and must say the setup was simple… now the part that gives me a headache… transfering about 3TB media files to the MyCloud HD. Tought it was simple… plug in HD in USB port and go… but no. OK watched the video how to setup and choose option direct connection… this is the set-up: Mac with 3 WD 1TB connected, network is at 1Gbit (I see 2 green lights on the WD MyCloud) connected Apple Mac (model late 2012) and WD direct with cat 5 cable, Transfer speed is on average 26MB/sec no matter if I divide the transfer from 1 disk or 2. If someone can tell me… this is normal or you can to this to increase the transfer speed I would be thankfull. (tried before with laptop but that one had no Gb network speed there was the expected 10MB/sec)

Software: tried to install the WD software WD My Cloud, but when it opens everything is blank… meaning no text and also no text in buttons. re-installing didn’t do the trick. Have this problem only on the Mac but works fine on Windows.

I don’t get this part “no matter if I divide the transfer from 1 disk or 2”. You are doing two transfer sessions from your Mac hdd A and B both at once to your directly connected MyCloud at 26MB/s? Multiple transfers will definitely slow down the flow.

For direct link to my lappy, I’m getting average 80MB/s single session both uploads and downloads. But that’s from Win8.1. Borrow a gigabit device and test transfers within the 3 devices to find the weakest link.

3 disks are connected to the Mac (WD Elements 1TB). If I do 2 transfers (from different disks)my average speed is 35MB/sec, while 1 transfer gives me 26MB/sec on average. Tryied also to copy first to Mac but did din’t improve the performance. I live in the Philippines and a quick visit to the shop for a gigabit router (a gigawhat??) is not so evident. :smiley:

I have also Apple Airport (with time machine) and there I can manage to have a true Gigabit connection (speed stays same when connecting the MyCloud). So the problem is in my opinion not the Mac and the attached USB drives.

problem stays the same

Screen Shot 2014-06-25 at 21.01.00.png

Screen Shot 2014-06-25 at 21.01.37.png

And this is how the WD My Cloud looks like on my Mac

You’re configuring speed and duplex manually.

That’s a TERRIBLE thing to do (unless you can do the same thing on your switch / router port being used.)

See Rule #1:

Put it to automatic…but

Screen Shot 2014-06-25 at 22.20.23.png

Screen Shot 2014-06-25 at 22.20.44.png

What I meant was to borrow another gigabit laptop (Windows preferably to eliminate Mac issues) and test with mycloud.

How fast is your Mac transferring from the usb(2.0/3.0?) hdds?

How fast is your Mac transferring from the Airport in your defined “true Gigabit connection”?

Can you confirm the actual link speed and duplex when you forced change the nic settings? E.g. in mycloud shell run below highlighted in yellow:

You need to test every link separately to nail the root cause…

1 Like

USB HD to Mac is not the issue

Screen Shot 2014-06-25 at 22.54.44.png

To and from airport arround 70MB/sec

I’m affraid that other testing has to wait for some time because I leave tommorow for my work to the Middle East. But thanks anyway for the advice and help. Will get to it when i’m back in 2 months.:cry: