Pubic Hotspot with "Terms of service" page

Back a few firmwares ago, I never had an issue with connecting to a hotstop that required me to click a block and hit submit. Now on the latest firmware, even if I try to use the close MAC feature (which honestly seems broken) I can’t connect, and therefor can not enjoy both a hotspot and my Mypassport wireless at the same time. 

Anyone know of any workarounds, or even a link or way to downgrade firmware (which I really don’t want to do)

I basically live traveling for work, and need this feature to work. It used too, now it’s nearly worthless. 

Can’t watch a movie and use iMessage

Can’t update my iTunes

Can’t surf while aorting files

Can’t do anything web related while working with my files. 

Making me disgruntled lol. 

I’m not sure what you’re talking about.

None of what you’re describing should have anyhthing to do with the MPW’s firmware – it’s entirely up to the mobile device to deterime how to use simultaneous WiFi and Cellular Data…

 even if I try to use the close MAC feature (which honestly seems broken)

Sorry, what’s that?  

I suspect that you meant a “Clone MAC” feature. I certainly haven’t seen that feature on the My Passport Wireless.

Even if it did work, and you logged into a hotspot on your phone, and then cloned its MAC Address to the MPW, you couldn’t have two devices with the same MAC Address on the network at the same time, so you couldn’t use both the MPW and your phone at the same time. It wouldn’t work, even if you disconnected your phone from the hotspot before connecting te MPW, then connected the phone to the MPW, there would still be two devices with the same MAC on a connected network, which is unlikely to work unless the MPW completely separate its wireless connection to a network from its wireless connection to a phone, when it is acting as a DHCP server. Still highly unlikely.

You could use your phone’s Wi-Fi to connect to the MPW, and its Mobile Data to connect to the internet, as Tony suggests. That should work, although sometimes if there is a LAN connection that doesn’t also have internet access, a device will just say there is no internet connection, rather than try the mobile data. They aren’t always completely independent.

How you get around a hotspot’s permission page or popup while trying to connect using the MPW, I have no idea. You need to ask the hotspot provider.

Yes, I meant “Clone” not “Close”. Sorry I fat fingered it.

The MAC clone feature is listed under the advance setting when connecting the MPW to a wireless network.

However, even if I use the feature, the MPW will connect to the network but the prompt for accepting TOS page never loads. I get the redirect and see the page trying to load, but it never loads.

I’m not trying to “get around the TOS prompt.” I’m just trying to actually connect my MPW to the internet through the hotspot.

As for the phone, I don’t have the hotspot feature, i’m using a Macbook and my MPW.

As for the comment above, the firmware i’m referring to is the same situation this guy has. There used to be a specific way to change the connection to a hotspot connection, according to the manual.

Okay. I see the MAC Address under the advanced settings, but as I am connected to it from my PC, it isn’t editable. Just checked settings in my iPhone connected directly to the MPW using My Cloud. Still no MAC Cloning. Using Safari browser on the iPhone to open the Dashboard, still no cloning. I don’t know where you see an option to clone the MAC Address. Sorry. I probably need a picture.

I didn’t mean that you were trying to bypass the TOS prompt and so connect without agreeing. I meant getting passed that point in the process so that you get a connection, by agreeing to the TOS. As you are using a Macbook, if I am correct to connect to the MPW, which you then want to connect to a wireless hotspot, maybe the Macbook is blocking the TOS popup?

The Dashboard is just a web page, so theoretically it could allow a TOS window to pop up. However, often hotspots that have a special log in and TOS, such as at an airport, require you to log in on their page, and not through something like the MPW Dashboard.

So, back to the statement: You need to ask the hotspot provider.

You do still have “Hotspot” functionality. Earlier firmwares used the terms “Private Network” and “Hotspot”, or similar, while the current firmware allows you to “Share content on this network” (Private Network) or not (Hotspot). So it has just been a terminology change. When connceting to a public hotspot, or any untrusted wireless network, just make sure you have the “Share content on this network” flag unticked.

Is this not meant to be a typical “Clone MAC” feature? The switch, on or off, doesn’t alter the devices MAC.  IMG_0260.JPG

Okay, now I see it. I had my network set to  “Share content on this network”, and when you do that the “Clone MAC Address” button is hidden. Unticking that option gave me access to the Clone MAC Address feature.

The wording of that popup help could be better, but it looks like the MPW is supposed to act like a router, allowing the MPW to present the MAC Address of a connected computer to the network it is connected to (the hotspot), rather than its own MAC Address.

I tested this feature on my MPW using the following connections:

iPhone 4 => MPW => My Router <= PC

I used my PC to access my router’s administrtion page and recorded my iPhone and the MPW MAC Addresses.

I used my iPhone to do the tasks you would have been doing on your Macbook.

I connected my iPhone directly to the MPW, then used Safari on the iPhone to access the MPW Dashboard, turn off the “Share content on this network” and turn on the Clone MAC Address feature. The MPW said it was updating the network connection.

I checked my router’s administration page, refreshed the connected devices page, and observed that there was no change to the MAC Address that the MPW was supplying to the router.

So I can only agree with you, that the Clone MAC Address function is broken. It doesn’t change the MAC Address supplied to the upstream network as it should.

Given that the Clone MAC Address function is broken in this firmware, it is reasonable to assume that something else is broken, or chaged, which is preventing you from gettng to the TOS page.

I think you should raise a ticket with WD Support, using the function in the MPW Dashboard so you can send all details. They may be able to help you get this working with the current firmware, but at the least they should test the Clone MAC Address feature, confirm it is broken, and fix it in the next firmware.

In the mean time, downgrading the firmware seems the only option. I thought I had kept a copy of the previous firmware, but it appears that I haven’t. Perhaps someone else has a copy they can share.

1 Like

I appreciate your help in validating that.  I unfortunately can not send a diagnostic report from the “Dashboard” because I can’t be on both that and the internet at the same time.  Once I get home in a week or so I can do that.  It would be highly appreciated if anyone had a link for a lower firmware in the meantime, I can’t seem to find one anywhere.

Thanks Roderick

You are welcome.

If you can find a hotspot that doesn’t require a TOS page, you may be able to send the diagnostic report. A MacDonalds perhaps?

Anyway, I searched by file name and found what looks to be a genuine copy of the firmware, version 1.03.13. However, it is not from a WD site. I downloaded it and tested it for viruses, and found nothing. The file size looks correct. So if you are willing to give it a chance, download from this page:

If it doesn’t work you can always just do a system reset. I believe that takes the MPW back to the version of firmware it was shipped with. But again, I haven’t tested that.

Let us know if firmware version 1.03.13 works or not. WD Support would probably like to know that as well.

Here is a link to the official WD download of v1.03.13 directly from my PC.  I download every version and install it via the SD card method and I suggest you do the same.  I have copied it to my personal cloud and you can download it from this link:

Thanks Mike. I downloaded a copy of your file as well. I have no idea where my copy went. Must be on an SD card somewhere.

BTW, your file and the one from the site I linked to compared identically using the Windows Comp(are) command. So the first one was probably safe.

No problem.  I imagined the other site was OK, too.  Who would go to the trouble of putting these things online if not to help?

BTW, how do I find/use the Windows (7) compare utility, it sounds handy?

Also regarding your comment  >>>> 

If it doesn’t work you can always just do a system reset. I believe that takes the MPW back to the version of firmware it was shipped with. But again, I haven’t tested that.

My experience is that it only went back to the built-in original FW if the reset to defaults was done improperly, meaning with the MPW off instead of ON.  Mine got messed up without the unit on.  Reset MUST be done with unit ON and MPW mostly fully charged.  In this case unit retained the latest FW.

mike27oct wrote:

BTW, how do I find/use the Windows (7) compare utility, it sounds handy?

It is one of the “DOS” commands available in a Windows Command window. It does a bit by bit comparison, after basic size and other checks. It can show you the lines numbers of differences and such as well. The command is “comp”.

I just use it mainly to compare two files that should be identical, rather than to analyse the differences.

Here is what it looks like:

Windows 7 Compare Commad Help

Thanks, I use to use it a lot during the DOS days, but obviously forgot about it since usinfgWindows for many years.  I will have to revisit the command!