Problems with My Book since Mavericks upgrade

Although my "my Book’ has been working after I updated to Mavericks, we had a power cut today and after which the back up failed again and again. Before reading about the firmware updates from WD I started a Disk utility to verify the disk which then told me it needed to be repaired.

It is in the process of repairing it but just wondering if Ive made matters worse by not doing the firmware updates before this? Help and advice woudl be welcome!


The disk utility on the mac said the drive needed repairing but after 2 hours could not repair. I went to erase the drive but it would not unmount it. I then tried updating the firmware and although it said it was what I had I continued. Restarted but to no avail. I am now uninstalling WD Smartware but it is taking ages in itself…

Have you tried to connect the drive to another Mac to see if you experience the same issue?

Ive only got my laptop and that has mavricks on aswell!

However tried to use Timemachine on another hardrive and it sdidnt work either but again not sure if there was enough space! I need to text the WD drive with another mac! without mavericks!I agree! Thanks for the reply!