Problems to restore connectivity with My Cloud

Hi to all. I bought 6 month ago a 3TB MyCloud, installed it with no problem and it was working normally. But recently I lost connectivity and checked that the front led was on white.
I tried to reset the settings, pressing more than 3 seconds the button or pressing the button at the same time switching on, but don’t happened anything.
I would be grateful, if someone know how can restore it.


Try to press the button for 40 seconds to see if this can help you have connection to the drive again. Hope this helps

I have the exact same problem. 3 TB MyCloud drive purchased 6 months ago. It has been working fine - Windows 8.1 Pro initially and now upgraded to Windows 10. I was able to see the MyCloud drive in the list of attached devices in my ROUTER’s admin rom. Now, it is not listed. The MyCloud LED on the front glows only white. I tried the 3 second reset and also the 40 second “system reset.” No joy. I can not access the MyCloud dashboard because I do not have IP connectivity through network. I would very much like any idea on how to correct this situation - I have had no unusual usage and everything worked very nicely until about 10 days ago. Feels like NIC in the MyCloud device not working. Any help would be appreciated.