Problems reading WD Passport 320Gb


#1

Hi all,

I’m having some problems with my WD external hard drive, and I’m not sure how to fix this.

The problem started recently after importing some pictures from a digital camera to my iPhoto library located in the external drive. I’ve imported the pics, and shared them to facebook with no problems directly through iPhoto. Afterwards I wanted to share a specific photo in my friends facebook wall but when I was trying to access my iPhoto library through facebook I got stuck. Could do anything on my computer, so I’ve restarted it. The WD drive mounts well, but doesn’t unmount saying that is being used by another application (which application I can understand). This doesn’t allow me to used disk utility to repair the disc, and even stuck all my attempts to scan and clone the disk using Data Rescue 3. The WD disc is formatted as MacOS extended (with registry).

Can someone point me out in a direction on how to recover my disk and its files?

Forgot to mention that each time I connect the disc 3 files appear on my recycle bin that I can’t delete. No sure if its related or not.

Cheers


#2

Turn the computer off / disconnect the drive / reboot the computer and then connect the drive to a USB port on the computer directly then try to drag and drop the files manually, If the drive works fine, this could be an issue with the third party software you are using, in that case you can use another back up software or simply back up your files manually.


#3

Hi there,  you can use  this utility to recover your data. Once recovered I will suggest to partition the drive and see how it go’s. 

Hope this helps.


#4

Thanks for your answer Wizer!

I’ve already tried to recover my data with 3 diferent software outthere and the result was the same in all, estimated time 1 month! I’m really not sure what to do next. I’ve unistalled and install again iPhoto just in case there was a problem with the this, no result.

My next move is to connect the disk to another computer and see if it works. I’ll keep updating my findings.

Cheers


#5

What I’m getting from you is that you can mount the drive, but can’t access any data.  If so, you may have corrupted the partition of the drive or some of the data. If you’ve tried recovering using a partition recovery tool and it doesn’t work, then there may not be anything you can do to recover the data.  Like you said, try it on another computer.


#6

Yes, that it.

I can indeed mount the drive, but the drive appears as empety, even though if I check the drive informations all the informations seems to be there, as the used and free space match with what was there.

A question: Do you think that if I formated the drive I would had more chances of getting the data back buy using some software?


#7

Formatting the drive will erase the Data, if the application is not able to see the data  then the drive is seriously messed up and you’ll need a more powerful application. You can try to repair the partition with First Aid or Disk Warrior and then see if you can get the info. 


#8

Hi all,

I manage to solve the problem with the external disc!!!
I’ve tried reading the disc in windows7 using MacDrive8 and voila,
all the data is the disc safe! I’m nos transfering everything to other drive, and then format!
Thanks for the help guys!
I’m a Happy man!!

Cheers