Problems booting up


i’ve owned a world edition 750gb for over 4years and it has always worked correctly. i use it as storage only, so i dont do much besides copying in/out files.

last nite a power failure in the household caused it to come to sudden stop, and it has not been able to boot up since. when connected to the power, the device runs, but the LEDs do not come on and nothing happens. the pc does not view a new device connected to the network either.

i ahve tried using the recovery button, read troubleshooting and the forum for quite a while, but nothing seems to work. all i can achieve is for the drive to run but des not fully boot up (apparently).

im not  technical person, thus my knowledge regarding these matters is rather limited. if someone out there may have an idea of how to solve this problem, it would be highly appreciated. my only concern is not to lose all the data i had in the drive.

thank you very much. best regards

I would definitely contact WD’s Technical Support about this. You can do so either by phone or email.  You may have experienced a power surge.

To Contact WD for Technical Support