Problem with viewing movies using the HDMI mode

For some movies that have dark scenes, the WD TV Live device does not show the dark scenes very well and in some cases the device cause my HDTV to black out.  To illustrate, I was watching a movie that had scenes which were dark.  The darkness in the scenes are similar to the darkness scenes you would see near the beginning of the movie Cowboys And Aliens.  I’m watching these movies using the HDMI mode.  These dark scenes causes the TV to show black on the screen just like what I would see when my television is turned off.  This problem doesn’t happen when I’m watching these movies using the AV mode.  In this mode, I would use the composite cable to send the signal from the device to my HDTV.  How can I resolve the darkness problem when viewing movies with dark scenes in them when viewing them in HDMI mode?


It’s your TV’s job to display the picture.  The WD is just telling it what to display…

Turn off dynamic contrast and/or brightness, and potentially LOCAL DIMMING on your TV.   

You could try going into the WD’s audio/video settings and manually set the color space value. This is supposed to be set automatically but sometimes it does not get set correctly. On my TV, the WD box frequently sets the color space to RGB High. When it is set like that my picture looks just like what you describe. With my TV, I have to manually set the color space to RGB Low for the video to look correct.

Thanks for the solution.  Changing the video setting to RGB low did resolve the problem. 

I also noticed the WD TV Live device uses the 720p resoultion by default.  I always wonder why the device won’t show the movies using the 1080p resolution since my HDTV does support  the 1080p resolution.  I had changed this in the audio/video setting.  The movies look a lot better using now using the 1080p resolution.