Problem with mybook world edition 1TB

I have a mybook world 1TB world edition that I am having some problems with.

I have two PC’s, both are running micrsoft windows 7 ultimate 32 bit. Both have all the latest updates, both are connected to a wired network, both are part of the same workgroup.

One PC works fine with the mybook.

I click on computer, then up at the top I click Map network drive. I typed \Mybookworld\public and left the drive letter as Z: and it worked fine.

On the second computer this is not the case. I tried to map the exact same path even using different drive letters (which should not matter) but it keeps saying the remote source will not accept the connection or something like that.

I’ve tried power cycling both the router and mybook to no avail.

What is strange is that before I had both of these computers connecting to the my book. I reformatted both PC’s, putting windows 7 32 bit back on (just as they had before) and now only one of the PC’s can map the mybook. The second computer refuses to map the mybook no matter what I try.

Any suggestions?

Try to use the WD Link software with your second computer, it might help you.