Problem with my WD TV Live


#1

I am not sure what happened but my WD TV Live suddenly could not locate the files that I save in my WD Element SE no more. Last week it still worked fine but today when I turned it on to watch some movies it keeps giving me this message: No Media in Local Drive. What should I do? When I plug the WD Element to my computer it works fine and I am able to watch the movies from there. However, with the WD TV Live, something wrong and I don’t know what happened. Please help anyone. Thanks.


#2

Welcome to the forums.

Plug the drive into your computer and delete the tiny “wd” file that is on it.  Attach it to the Live and see if that makes any difference.


#3

Just adding to Mike’s comment, what you are looking for is a hidden folder named wd_tv. The folder contains the WD TV Live database of all the media on the drive. If deleting it does not work then the partition table may be corrupt, in which case you’ll need to run an app that will fix the partition table without deleting the content of the drive.


#4

Thank you Jackster and Mike. I followed your instructions  and it works now. Thanks again. You guys are genius.


#5

I’m glad it worked out for you!  :wink:

You can go ahead and mark this thread as solved then.  I’ll give my proper kudos to Mike’s original post!