Problem with My Book Elite


#1

I just recently purchased the 1.5 TB My Book Elite and everything was working well until just recently. When I opened the WD Software and checked to see if the drive needed updating, I saw they had a firmware and software update available. I downloaded both, but when I installed the firmware update (Apollo 1607E Firmware Updater v1.032 (1.0.7.4)) my drive no longer connects to my computer. I’ve tried unplugging the drive multiple times, restarting my computer, and using different USB ports, but still nothing. I made sure to follow the installation instructions too. My computer Operating System is Windows Vista Home Premium.

I have another 1.5 TB external hard drive that is a different brand and it works just fine. So I’m guessing that firmware thing messed up the drive somehow, even though I got it here.

I’ve already transfered over 900 Gbs of files onto the drive so it’s kind of important I can get this thing working again.

Any help would be much appreciated.

Thank you for your time.

Edit: Nevermind, problem solved. :stuck_out_tongue:


#2

I have the same problem with a My Book Essential 2.0TB.  What is the solution going nuts for two hours help please.


#3

How was this problem solved???

I’m having the same problem with my MyBook Elite1.5TB since yesterday when I upgraded to 1.2.1.26.

The software comes up, but My Computer does not show the drive. I can’t unlock it and access my files!

Please help me!