Problem with my 1TB Passport 3.0

Here is my issue: The HD had been operating fine since I bought up until  two days ago when i arrived in theater. Now, I have tried following some of the wirte-ups on the site and to no avail. The laptop does pickup that the HD is connected(Devices and printers and Device Manager), but for some reason when i go to My Computer, Device Managert, or use HDtune there is nothing there. I went through the Properties menu for the HD and tried to populate it or format it or anything it saya there is no device there. 

       The HD is constantly spinning and the light is steady when i plug it in, and it has fallen before(might be the issue). I am hoping you guys can help. It will be a long deployment w.o this ■■■■■■, but at least I will have an answer. Thanks and sorry for the terrible structure.

I have faced a similar issue, still looking for a solution. Western Digital suggested an RMA, I would do that if I didn’t have important files on it.

When you plug it in does do programs freeze, and not restore till you unplug?

I find sometimes it works after 10 or so minutes.

I’ll try the RMA really don’t wanna but  eh. I have had it come up but only for a split second.